Power front windows [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Power front windows


USPEEEDIWRITE
01-12-2004, 05:58 AM
Anyone else experience problems with the front power windows not working? I have a 2000 GT. And lately I have been experiencing problems with the front windows. My passenger window will not go down any longer and the driverside stops every so often, but then starts working again. Rear windows are working , no problems . Thanks for any feed back ~

Shaun ~

BLKSHDW
01-12-2004, 06:42 AM
well depending on the milage, take it back and warranty it otherwise go on to ebay and buy to brand new window motors and replace them... if that doesn't do it then i don't know

VaGT
01-12-2004, 07:46 AM
Window regulators are a very common problem in the GA. I've had both of my front ones replaced (warrantee). The part runs about $250 from the dealer, and probably takes an hour to install.

You can get the part cheaper from other sources though.


Just do a search for regulator or window regulator on this forum.

SteveGT1
01-12-2004, 07:48 AM
Is there a difference in the window regulator on a 2 door and 4 door GA? If not would a rear window regulator on a 4 door fit the front on a 2 door?

thehemi
01-12-2004, 08:29 AM
Our '96 GA had them replaced in '02.
Actually, just the driver's side, but the
dealer did both of 'em under warranty.
Altho... they used some crappy motors.

IAmCanadian
01-12-2004, 08:36 PM
In another thread about finding parts for your car at junkyarddog.com, they have another link on their site for replacement window motors and regulators.

http://www.a1electric.com/catalog/cat_pontiacmtr.htm

Decent looking prices and you get only what you need/want.

Tonyyank
01-12-2004, 09:39 PM
^ GOOD FIND!!

USPEEEDIWRITE
02-18-2004, 05:44 AM
Well my warranty does not cover "wearable"parts .Either part will cost me at least $250 each to replace not including labor, and now my passenger door will not unlock automaticlly when the car is shut off. I hope this car doesnt turn into a lemon on me :( . My passenger door is completely dead now....

rodd62
02-18-2004, 02:31 PM
the 2 and 4 are different...i found out the hard way...but the motors are all the same. sounds like a bad/bent track or the motor is old. could also be that the cable has been crossed where it goes thru the motor causing extreme wear on the motor and you may need to replace the regulator and motor if that is the case.

Vince
02-18-2004, 02:47 PM
I wrote something about this on the other thread "Power window stuck", so take a look at that and see if that helps. But there is one more thing, on mine, I found out that the window attachment to the track came loose. Not the bolted part, but the glue ON the window itself. This cause the window to tilt, causing the the motor to freeze, and then eventually causing the plastic clip on the track to break. If I had known this before, I probably could have avoided buying a new set up. Good luck.