help!!! low oil pressure/ crappy mileage [Archive] - GrandAmGT.com Forum

PDA

View Full Version : help!!! low oil pressure/ crappy mileage


Turbodreams-se
01-14-2004, 08:37 PM
ok This freaks me out... I have noticed my mileage going dow since i got the car, it was going at about 30-32 mpg, and now its at ~18 mpg. wtf and then today, my oil pressure light came on... not the change oil light, the one with the little oil can. but the light didn't stay on. it flashed on then went away. it's done it twice today but i didn't see it the first time it just made the chimes and by the time i looked down the light was gone. does this light usually stay on or just flash? I did a search but found nothing. i checked, and my oil level is good, it was just changed maybe 1000 miles ago.
anybody?

Costa
01-14-2004, 09:58 PM
Well when gaskets are going bad, usually you see the low coolant like come on and then go off again within a few seconds.

So im guessing it's normal to see a code light flash, but it definitly means something is wrong. Have it checked out.

Turbodreams-se
01-14-2004, 10:28 PM
but it just flashed once and went away... it wasn't even illuminated for a full second. but it wasn't the coolant light either... the only time i ever saw that light was on my old car after i replaced the turbo and didn't think to put new oil in altogether... that fixed the problem... maybe its the same thing but i haven't dabbled with a turbo on this car *yet* I will change my oil in the morning and see how much that works.

killerhound
01-15-2004, 10:01 AM
Have it checked. My coolant light did that and I ended up having a bad gasket.

Turbodreams-se
01-15-2004, 04:27 PM
I changed my oil today and somehow, the filter was leaking... i examined it and the rubber grommet around the edge was all torn up... so problem found and solved... i had about 1 1/2 qts of oil left... thanks for ideas though.

2002AmSE
01-16-2004, 05:14 AM
Ahh, good to know it is fixed now, and its not some other major problem.

:rolleyes: But when you said that your oil level was good, usually 1.5 quarts left isnt good... :p

atc3434
01-16-2004, 11:44 AM
Geez, only 1.5 quarts left... you'd think the Low Oil sensor would have picked up on that. Better not depend on that idoit light either. GIVE ME GAUGES!

Turbodreams-se
01-16-2004, 03:30 PM
well I checked it that night that i had the light coming on and it was up almost at the full mark.... but then overnight a lot leaked out... unfortunately, now i have a new problem... I think it is one of the belts or the timing chain... hopefully not the latter... that is a b*tch to get to... my car is making a clicking sound on acceleration, and clicks slowly on idling. any ideas?

2002AmSE
01-18-2004, 06:08 PM
I was just riding with my friend in his Mitsubishi(probably a 95' or something) from his house, and its one of the coldest days lately(surprised that there isnt snow), and he started his car, it sounded like it was barely going to, but it did. We thought the battery might have been a little dead or something, even though he has a brand new battery and his starter is fine. Well, we were driving and his power steering goes nuts, and gets stiff for a short while along with some strange noises and back to normal. Well we make it to the gas station where we were going to be picking up pop and some munchies. We open the hood and see his power steering pump resovior had gotten super frothy and it ran over and spilled all over, we thought that was the only problem. Well anyway, as we drove from his house to the gas station the oil light came on, so we checked his oil and we had to put 2 quarts in to bring it back to level. We have no clue where all that oil went, the car had an oil change about a week ago, and somehow the level dropped, but what was weird was the oil already looked dirtier than what my oil looks like after 3000 miles, jet black it seemed.

Im not asking for questions or comments, just randomly telling a story.