intermittent ABS and ETC lights [Archive] - GrandAmGT.com Forum

PDA

View Full Version : intermittent ABS and ETC lights


zom91
01-21-2004, 12:55 PM
My girlfriend has a 99 ga gt, and this is her first winter with it. The problem is that the ABS and "TRAC OFF" light go on and off intermittently, sometimes together and sometimes seperately. She tells me that the car even drives differently when the lights come on, as far as resistance in the steering wheel (loose feeling) when turning the car. She has talked to a couple of fellow GA owners and a local dealership about the problem, and she was told that a sensor near the wheels will get covered with sand and ice during the winter which causes the systems to malfunction, and they said this was normal on the GA's. Personally, I find this pretty hard to swallow. The ABS and ETC systems are vital systems to the cars integrity, and it is very hard for me to believe that this would be considered "normal" for these cars. If this is that common of a problem, then I would expect there to be a recall for something this important but I can't find one. Is what she's being told true? If so, is there a way to clean the sensors and possibly find a way to help prevent this from happening? Any help is appreciated.

Doug
zom91@hotmail.com

pontga00
01-21-2004, 01:38 PM
I have the same problem with mine...except the brake light and trac off light go on and off only when i hit high RPM's on the highway...whenever I get over 90 mph it happens.

iceman
01-21-2004, 01:40 PM
That is a common problem, the people you have talked to are correct. Something in the wheel hub - search around and you will definitely find the cure.

Mike_99GAGT
01-21-2004, 08:23 PM
same problem here........everything starts fine and both ABS and ETS systems work fine untill about 5 km down the road.....sometimes "low trac" light will come on when i'm at a stop.....then usually ETC and "TRAC OFF" lights come on, and remain on untill i shut the car off and restart it.....but once again

i'm taking it in at the end of the week to have the computer read for any codes.....i'll reply with any findings......

ttyl

Mike_99GAGT
01-24-2004, 10:07 AM
Originally posted by Mike_99GAGT
same problem here........everything starts fine and both ABS and ETS systems work fine untill about 5 km down the road.....sometimes "low trac" light will come on when i'm at a stop.....then usually ETC and "TRAC OFF" lights come on, and remain on untill i shut the car off and restart it.....but once again

i'm taking it in at the end of the week to have the computer read for any codes.....i'll reply with any findings......

ttyl


Well, Turns our My Right Front wheel sensor, is coding "EXCESSIVE WHEEL SPEED".........could be the sensor, but i find it weird that sometimes everything works fine.....very odd........well, i'm gonna wait this one for a while, see if it fixes it self.....or untill the blocks of ice and road crap melts off my car.......

anyone else experiencing this problem????......and what was your fix??

thanks again

Alkaholik
01-24-2004, 11:28 AM
Make sure she gets GM to do an ABS inspection, my lights ABS and ETC and TRAC OFF all came on and the problem was that the ABS harness had shorted. My light actually came on again but ABS is still working.

Rogue9
01-24-2004, 01:04 PM
sounds like faulty wheel speed sensor...
which is why they took off the tire pressure light in the later models.

Comp kept thinking the tires were flat at the slightest unequal spin.

Mike_99GAGT
01-24-2004, 01:11 PM
Alkaholik!!!......which harness shorted out??......where is it located??.....

thanks

Rba007
01-24-2004, 01:11 PM
I had the exactl problem, only mine was caused by a vacuum leak. My TB is held on by two bolts, and one of them had worked its way out... Embarassing, but replacing the bolt fixed the problem.

coupe
01-25-2004, 05:24 PM
I get ABS and TRAC OFF lights also. No reason at all, they just come on. My security light also comes on and wont let me start my car once in awhile.

carpediem1230
01-26-2004, 12:11 AM
I guess i should consider myself lucky that i never get anything like that with my 99 GT. none of those trac lights and ABS lights, except when i'm playing=)

Alkaholik
01-27-2004, 03:41 PM
The actual ABS wire harness shorted like I said I hope she has a warrenty still since it cost $475 to replace, make sure you go get an ABS inspection, I'm pretty sure it's free