Rotten Egg Smell and SES light [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Rotten Egg Smell and SES light


djrkd
02-05-2004, 02:55 PM
I had the SES light come on, went to autozone to get it read, and got a 404 or something code, regarding the exhaust, the guy almost noticed the rotten egg smell, so it must be the catalytic or the O2 sensor? I did a search for rotten egg smell, and no one mentioned the SES light comming along with the Catalytic being bad, How would the computer know when the cat goes bad? So can the O2 sensor trigger the light and cause the bad mixture? The car is stock besides a WAI, the only different is putting 93 octane last time I got gas. The car has about 33k miles on it.

01silverGT
02-05-2004, 03:34 PM
yes the cat did probally go bad!! your check engine light is on because there is a O2 Sensor after the cat and it is probally going crazy with all the bad exhaust gas going by!

djrkd
02-05-2004, 03:39 PM
I saw someone mention that GM covers it up to 80,000 is that true?

Dr_Kyle
02-05-2004, 03:49 PM
It should say in your owners manual. I believe it is 60k or something near it.

djrkd
02-05-2004, 04:00 PM
cant find nothing in my manual :\

edit:
I called GM and they said 80,000 miles on the Catalytic and PCM. So u guys deff think its the catalytic?

matts
02-05-2004, 10:25 PM
that's what i would think too

kubiache
02-06-2004, 04:27 AM
So u guys deff think its the catalytic?

Yes, but the problem is WHAT caused your cat to go bad. Your car is only a '99, not that old. Chances are your car is running really rich for some reason, as that kills cats very quickly. So you're going to have to have them figure out why you're running rich (if that's the problem). If you just replace the cat, it'll more than likely go bad again until you find out what is the root problem.

01silverGT
02-06-2004, 05:49 AM
the infamous phrase..."sh** happens" is what caused it to go bad more then likley, you have a 8 year 80,000 mile warrenty on the converter so go get a new one!

71Z28RS
02-06-2004, 06:18 AM
I'd be tempted to replace the O2 sensors too, just to be safe.

djrkd
02-06-2004, 06:46 AM
are they going to say my WAI caused it to go bad?

coupe
02-06-2004, 11:56 AM
I have the rotton egg smell to. I dont think it is the cat though because it is a brand new carsound highflow cat that is about 5 weeks old. I dont have any lights though.

Kdawg207
02-06-2004, 11:57 AM
Originally posted by djrkd
are they going to say my WAI caused it to go bad?


i will bet 5 bux they do


it's only a WAI...swap it back to stock b4 you take it in

djrkd
02-06-2004, 11:58 AM
if its not the cat, there gonna make me pay 90$ just for lookin at it, I really dont wanna waste the money.

djrkd
02-06-2004, 01:25 PM
just got back from midas, they said its not the cat.

Kdawg207
02-06-2004, 01:37 PM
did they tell you what it is...or just what it's not

coupe
02-06-2004, 01:47 PM
Yeah what they say?

djrkd
02-06-2004, 01:51 PM
they said they dont know, im gonna remove the O2 sensor, see if it looks bad. The smell is gone though.

coupe
02-06-2004, 02:56 PM
I get the smell only once in awhile and its for only like 30 seconds then it goes away.

djrkd
02-06-2004, 03:10 PM
do u have any mods?

coupe
02-06-2004, 03:36 PM
Um yeah.
Recent addiction SS headers. My cardomain isnt updated yet so they arent in there.

djrkd
02-06-2004, 03:37 PM
i see, im worried i wont be able to pass inspection this month.

coupe
02-06-2004, 03:44 PM
Thats gotta suck to live in a state that has that inspection crap. I dont have a O2 sensor or air tube in my cat, would i pass your states inspection?