Signal Light Flasher Noise [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Signal Light Flasher Noise


SwatZeR
02-08-2004, 10:20 PM
I have a 2000 GAGT.

I have some weird issues with the sound that my signal lights make. When I turn on my signal light, after I come out of my turn, the lights go off like normal but the sound keeps going and will go really fast like someone is flicking the flasher really fast.

It only stays like that for a minute or so and then goes off. Then it might do it later on when I am driving for no reason at all!

When I brought it, they could hear the fast clicking noise, and they said it was a problem with the hazard assembly and replaced it. But the problem is still happening. One of the service reps said that they should have replaced the multifunction switch instead.

Anywho, to make a long story short, I have been trying to get this problem taken care of, but whenever I take it into the dealership the sound will not stay on so that they can actually hear it! They only heard it the first time when they replaced the hazard assembly.

Now they want to hear the noise again before they can go ahead and replace the multifunction thingy. But I can't just make the noise happen...it's totally intermittent!

What would you suggest? I have taken it in three times to get it checked out, but they never hear the sound...I swear my car knows when it gets near the dealership!

AznGA
02-09-2004, 12:14 AM
I had a smiliar problem. Turned out to be faulty signal lever.

SwatZeR
02-09-2004, 01:17 AM
How did you get it fixed?

AznGA
02-09-2004, 01:26 AM
They replaced the lever under warranty.