1999 Abs [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 1999 Abs


RAPTOR
02-18-2004, 08:31 PM
I need some tech info,my 99 gt 3.4,has a little abs problem.the abs and the low traction lite is staying on.when i turn the key to on it makes this really wierd noise,sounds like it coming from under the battery.god i hope this is not going to be one of those 1000.00 bills to the garage.thanks for any advice.i'm pretty good with a wrench so maybe it's something i can handle

EBlend
02-18-2004, 08:46 PM
maybe ur abs sersor is messed?
doesn't it share itself with the trackion as well?

RAPTOR
02-18-2004, 09:08 PM
do you know where this sensor is,and is it a dealer part only.is it like a 500.00 part

thehemi
02-19-2004, 07:34 AM
We had front ABS sensors replaced 2x in
my wife's '96 GA. Finally just unplugged
the damn things and live without them.

2 different dealerships, too, so we want
to think it was not lack of dealer training!

If the dealer cannot fix it, how can I? :)

RAPTOR
02-19-2004, 05:00 PM
Here's the deal guys,took everything apart this morning.the brakes where gone,with only 20 thousand miles on new rotors and pads.the passenger rotor was all rusted up the floating pins,where rusted solid.what a job to get them out.put new rotors and went with the bendix pads this time.all the lites when out and i'm good to go.i really hate this cars brakes this is my fourth set 58800 miles,i mean come on,i never seen anything like it.can anyone explain to me why this thing is eating up brakes every 20 grand.my ford truck has 90 grand and only done them once.my R1 has had a couple sets,170 mph sure does eat up a pad.LOL.my 04 should be in next week:D

JesseGT1
02-19-2004, 07:41 PM
theres got to be something wrong with your calipers. Ive put over 30k on my current set (rotors and pads cheap ones too) and there only about 50% worn. Or you do ALOT of hard stopping.