Power Steering [Archive] - GrandAmGT.com Forum


View Full Version : Power Steering

02-21-2004, 04:51 PM
Well the power steering gave up on the car yesterday (Y2K GA SE - 3.4l), now I need body builder arms to drive!!!

Any ideas on what it most likely is??? (Known problems...etc) There are no leaks, fluid is not down, and no weird noises, and the belt is OK, all other accessories running fine.

The pump was replaced about a year ago under warranty because it was very stiff at idle. They said it was shot, installed a new one and the problem was fixed.

02-23-2004, 07:43 AM

02-23-2004, 08:04 AM
My vote is your pump has failed.

Just a guess though.

02-23-2004, 12:06 PM
I would say pump as well.

02-23-2004, 05:46 PM
Could also be the rack and pinion, but since you just had the pump replaced recently it most likely is the pump (or the control valve in the pump stuck open)

02-23-2004, 07:20 PM
Mine just went a couple of months back. The shaft just snapped on the inside is what the dealer said. Now the new pump is leaking :-/ time to take it back and bitch.

02-24-2004, 08:20 AM
Found the problem after talking to the dealer (this part isn't covered under warranty). The shaft is cracked off in the pump, aparently not uncommon for these cars. Priced a used one from a 2002, $75 CDN, plus I can install it myself.

Much better than the first garage I went to who said it was the rack ($300 CDN plus about 5-6 hours @$40 per hour!!!)

Thanks all for your help which ended up with me not having to pay someone to replace a rack that isnt gone!!!

02-24-2004, 09:51 AM
I blew my pump after doing a reverse donut in snow. Couple monthes after they replaced it, I noticed my power steeing fluid is leaking. They ended up replaceing the rack and hoses. All under warranty.

02-24-2004, 10:39 AM
Wow, maybe my hoses are ****ed :-/ thats kinda were it looks to be leaking. In a couple of weeks over spring break I'm taking it back and getting it fixed before my extended warranrty runs out.

02-24-2004, 04:20 PM
I had mine replaced twice because the crappy pump crapped out.