Help me. hesitant when accel. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Help me. hesitant when accel.


tido_29
03-01-2004, 01:35 PM
So this problem started about a month ago. I turn on the car and everything runs fine. Then i put it in drive and as i start to press the accelerator, the car starts to chug back and forth. then when i sit at a stop light, it start to shake a bit. The Check engine light turns on (at time) and blinks for about a minute or two.

I changed the spark plugs and fuel filter.

What can be the problem?

I took it to autozone when the check engine light came on and it said "multiple engine misfire" and "O2 sensor". The guy said not to jump on the O2 sensor too soon since the bad misfireing can make that go off.

Please help me :(

Dr_Kyle
03-01-2004, 02:16 PM
Dirty injector, bad plug wire, or a bad coil.

Most likely one of the first two.

tido_29
03-01-2004, 02:51 PM
I am going to change the plug wires today. if that doesnt fix the problem, i will check the pump. How can you check the celenoid? w/o having to buy new ones.

I know someone said that if it was a certain cylinder misfireing, then you can switch the celenoids and see if the mistfire goes to another cylinder.. then you know its the celenoids that are bad.

but what if the code says, multiple cylinder misfire?

Costa
03-01-2004, 11:44 PM
Been there done that.
Problem: Dirty fuel injector.

tido_29
03-02-2004, 01:12 PM
well changed the spark plugs.. turns out 2 of the 6 were really burned (guess they were too close to the engine block). i mean, i bent them and the rubber broke...

feeewwww.. this could have been costly.

juanvan
03-02-2004, 05:27 PM
Check that the plugs were right ~ had some in a honda *cough* opps that just happened in ~ the plugs were wrong
Got to love the newbies at the auto store :-p