My car just freaked out... need some help. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : My car just freaked out... need some help.


Jaysin
03-01-2004, 06:44 PM
I was takeing my girl and my daughter* http://www.jdthiele.com/ket.html (yea I have to show her off too) but anyway... we wree on our way to the chinese buffett ;) And my lights got dim... My ABS light came on, my change oil light came on, my check tire pressure light came on (well actually thats been on since I got the car) And then as I slowed down I realized that I had no power stearing..... I know I have a leak in my power stearing as I stopped at a pepboys right before getting to the resteraunt and filled up my power stearing fluid as I thought that was the problem... and it seemed to fix the power stearing and the low light problem (maybe a dry PS pump was straining the alternator?) BUt anyway after we finsiewd eating and were leaving I noticed a large pool of PS fluid under the car, and I had no PS once again. ... now perhaps the fluid got on the serp belt as it was leaking and was causing slippage on the alternator? Would that explain the lights comeing on? Oh... and does anyone elses PS pumps make a funny noise? Mine always has.. I can get a reman pump for about $35... but I have to beat that little flange thing that the GAs have on theres off with a sledge hammer and put it on the new one ( i did this before) So anyone have any ideas about the lights/power failures in relation to the Power stearing? BTW I have a 99 GA GT w/ a 3.4 http://www.jdthiele.com/99gagt.html hehe check it out. Also... if its a hose thats leaking, how hard is it to replace the hose, how expensive? And would A leak have anything to do with the rack and pinion? I dont even wana know how much that would be.

-Jay

Blackrider
03-01-2004, 06:50 PM
Yeah If you got PS Fluid on the bet it would cause slipage and your alt would have a hard time keeping up, this also explains the Electrical system freaking out, that usualy happends with Alt Problems.

Congrats on the Little Girl! :cheers:

Jaysin
03-01-2004, 07:11 PM
Thanks =) And do you know if the hose(s) are expensive or hard to replace? (I never bring my car to a shop, cant afford it LOL)

-Jay

Jaysin
03-02-2004, 11:20 AM
Welp it turned out to be the pump, the back of the pump, side closest to the motor was busted open.. guess where the leak was comeing from? LOL so anyway I had takein the pump off, took the vairable steering speed and 90 degree hose flang off the old PS pump... took the pulley off... put all the stuff on the new reman pump... went to put the pulley on the new pump and.... the pulley installer litteraly shattered the pulley *sobs* but whats worse is that it was like 1/8 inch from being completly on... so now I gata find a way to get it off... I bought a new pulley for $20 at pep-boys... hopefully this one wont break ;) Wish me luck....


-Jay

Blackrider
03-02-2004, 11:43 AM
Originally posted by Jaysin
Welp it turned out to be the pump, the back of the pump, side closest to the motor was busted open.. guess where the leak was comeing from? LOL so anyway I had takein the pump off, took the vairable steering speed and 90 degree hose flang off the old PS pump... took the pulley off... put all the stuff on the new reman pump... went to put the pulley on the new pump and.... the pulley installer litteraly shattered the pulley *sobs* but whats worse is that it was like 1/8 inch from being completly on... so now I gata find a way to get it off... I bought a new pulley for $20 at pep-boys... hopefully this one wont break ;) Wish me luck....


-Jay

Good to to hear man, be glag it was the pump and it was that easy to fix power steering lines are a pain in the ass

blk_grn_97GT
03-16-2004, 05:12 AM
if you guys could look at my thread and see if it might be the same problem?