Fixed my power windows, but still have a question. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Fixed my power windows, but still have a question.


jordanGT
03-09-2004, 08:47 AM
I replaced the clips on the window regulator this morning. (If you don't know what I'm talking about, check out this thread: http://www.gaownersclub.com/forum/showthread.php?s=&threadid=20956 It could save you some money over buying a whole new regulator) Everything works great. Just one question, though. There's still a gap where my window should seal at the top. I thought replacing the clips would fix that, but it didn't. Any ideas on how to fix it before I put my door panel back on?
http://images.cardomain.com/member_images/12/web/396000-396999/396228_80_full.jpg

71Z28RS
03-10-2004, 07:03 AM
I'm wondering if it's possible they gave you the wrong part. Did you compare it to the broken one? If the motor/regulator is good, it should have no problem closing all the way. Did you remove the whole assembly? If so, did you make sure the spring tension stayed where it was at? If that unwound at all, that could be a problem too.

jordanGT
03-10-2004, 09:27 PM
the gap was there before i replaced the clips. the clips were definitely the correct ones. i thought the window's sag was due to the one clip having broken off completely, which obviously wasn't the cause of the problem...

craig02GAGT
03-12-2004, 06:02 PM
Is there anything that is interfering or stuck in the channel the window slides up in?

71Z28RS
03-15-2004, 07:47 AM
If the window works really slow, I'd say it's your motor/regulator. Unless somehow the window track is broken or something, but usually that results in a crooked window.