weird chugging funky thing going on... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : weird chugging funky thing going on...


tctr13
05-27-2004, 10:38 AM
first time poster here, so please be gentle... :-)

the situation is/was like this...

this morning, after about 15 mins of normal city driving... stopped to drop off the wife (car still running)... stopped at stop sign pushed on accelerator (non-aggressively) engine revved but there was a short pause (1-2 seconds) before it kicked in... that has happened b4 but what happened right after is what worried me... 3 seconds after I started to move the car started to violently chug and hesitate until a few seconds after I took my foot off the gas... I also noticed that the speedometer needle swept all the way to the right (weird!!!)...

pulled over for a moment until everything settled down and then went on my merry way as tho nothing had happened...

anyone have any ideas or similar experiences???

'99 GaGT
oil every 5k km's

preed4962
05-27-2004, 11:57 AM
I had a similar situation to this once in my wife's 97 Sunfire right after an oil change. Apparently the connector to the transmission had been knocked off, and therefore the transmission didn't know when to shift. The only thing different than what you are explaining is that in my situation the speedometer and tach didn't work at all. I guess what it boils down to is that you may have a loose connection somewhere on your transmission.

nomojo
05-27-2004, 04:32 PM
If you're so lucky, it could just be the shift linkage is misaligned.

More likely though you have a actual problem with your tranny. Take the car to a dealer or autozone or somewhere where they can scan the computer for error codes.

cheers.