Tps? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Tps?


AznGA
05-31-2004, 08:50 PM
I think my transmission is fine, because during WOT, it shifts smooth, no slippage, no RPM bouncing up and down. But when I cruise slowly, when it's trying to shift from 2nd to 3rd, the car keeps jerking and the RPM bounces up and down. I give it more gas, and it finally shifts. I am thinking it has to do with throttle position sensor?

mikes00GAGT
10-09-2004, 02:04 PM
Hey AznGA,

I am experiencing the same problem with my car. I took it to the dealership a few months back and they said my car was running Lean and wanted to replace the fuel pump, but said, they could not guarantee replacing the fuel pump for $700 would fix the problem.

So, I took it to 2 other places and the most recent place said it was throwing codes for a bad throttle position sensor, so I replaced that myself today, but that doesn't seem to have fixed the problem.

Have you had any luck fixing this problem with your car?

AznGA
10-09-2004, 04:11 PM
Now I think it's having problems shifting into 4th. People have told me it could be something like torque converter lock up solinoid sticking due to bad tranny oil.

2002AmSE
10-10-2004, 12:07 AM
I think only one person said the trans. fluid would be the cause of the convertor lock-up solenoid not engaging. Looking at past threads, this is usually something that people will first reset the PCM by pulling the negative battery cable, and if that doesn't fix it, people have found the culprit to be the lock up solenoid to do it.

I know I posted about this and how to tell if its your solenoid, so do a search for torque converter lock up and you will find info on this. I would explain it again but I havent got the time to.