Help me ASAP [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Help me ASAP


Lilred96gagt
06-02-2004, 08:00 PM
:crying:Okay I have Nopi in two days and my car is acting up big time. I hooked up my OBD2 and got this for a code P0141: O2 sensor Heater circuit malfunction (bank 1 sensor 2) I replaced the O2 and the engine coolant temp sensor and the cooling fan isn't coming on. So when ever my car reaches normal running temp according to the gauge and then it stalls and i can't restart it for like an hour or until it cools down enough. Today I replaced the Relay in the car but I'm afraid to take it out for a test drive because I don't want it to stall and not be able to get home. Do any of you guys have any idea as to what this might be. To remind you I have a 1996 GAGT w/ the 2.4 in it. Any help would be GREATLY appreciated.

gobraves02002
06-02-2004, 09:44 PM
sounds like how my car was acting when i needed my fuel pump replaced

sweet98gagt
06-02-2004, 10:18 PM
not for nothing, but jack up the front end and pretend to drive it around... i mean i know you wont have air blowin on the radiator or nothing, but u can accel and slow down normally just to see what happens

also, get a buddy w/ a truck to follow u so u can get a tow back if it acts up

Lilred96gagt
06-23-2004, 10:11 AM
Well its finally fixed. I replaced the O2 sensor, Engine coolant sensor, oil switch, cooling fan relay and a few hoses and the car was still stalling after it would reach noral temp. Well I finaly found the problem. Crank Sensor. Car runs GREAT especially with the "secret cams" in it now. I love this thing. Can't wait to get it to the track this weekend. I have some unfinished business left from last year to settle.