PS Pump Cap Question [Archive] - GrandAmGT.com Forum

PDA

View Full Version : PS Pump Cap Question


swordfencer
06-16-2004, 07:11 AM
A few days ago, I noticed a 'clicking' or 'rubbing' noise coming from my power steering pump. I just had the belt replaced 300 miles ago because it was chirping, again coming from the power steering pump area and the belt was pretty worn The belt only had 27,000 miles on it.

After the belt was replaced, I did not hear anything from the pump until a few days ago. I looked at it and noticed the cap had fluid around it.

I just got back fromt he dealer, and they did not find anything wrong with the belt or pump, just the cap leaking, which they ordered a new one. My question is:

Could a leaky cap cause a pressure problem in the system that would lead to a noise coming from the pump? Also, what would cause the fluid to all of a sudden leak out of the cap? The only thing I can think of is that I have a pressure issue in the system.

2002AmSE
06-19-2004, 08:20 PM
I don't think all of your fluid would just come out of the cap quickly, because when ive got my car on and i take the cap off, the fluid isnt shooting out or anything. I just don't think it all came out very quickly.

My mom's GA had her pump run dry, and having it run dry will burn out the pump and it will start making noises before it burns up.

My car however, the belt is pretty much gone for me too and it isnt the first time for it to go either. The squeaking has always been around the PS pump for me as well. I'm wondering if the pump has anything to do with your belt failure or possibly my belt.

Panacea
06-19-2004, 08:21 PM
I have a little liquid residue around my cap. I've asked the dealer about it and they say it's normal. I've not had any problems with my power steering.

Mike_99GAGT
06-08-2005, 09:04 AM
i know this is an old thread.....but does anyone know if there is any sort or filter or screen inside the resivior or PS system that could get plugged an not allow fluid into the rest of the system??.....i've had a whining noice for the last couple days....fluid is fine, but not getting very warm even after 10 mins of driving, in this smokin hot weather....any ideas?

thanks

AznGA
06-08-2005, 09:39 AM
I once had a leak around the power steering cap. Turned out to be one of the hoses.

badboy2451
06-08-2005, 12:49 PM
isn't there a tsb for this problem, something about to much pressure in the system cuasing fluid to seep out...i think the solution was something along the lines of drilling a hole in the shell to let off some pressure


anybody back me up on this??

Joker694
06-08-2005, 01:16 PM
#99-02-32-002 Tech - Pwr Strng Sys Noise Concerns (Replace PSS Hose, Enlarge Sys. Restrictor) - (May 7, 1999)