Bad Alternator? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Bad Alternator?


Kodeblue
08-03-2004, 04:15 PM
Lately I have been hearing like a squeel sound and when I pop the hood, it seems to be coming from the alternator. I have no way to confirm this though. Alot of times, if I leave my ignition to on and I can even have the stereo turned down to "0", the battery will be dead in about 15 minutes like this. It happened again today. ANyways, I boosted the car with no problem and things were fine for the drive home. I just went out to leave and now the damn car just clicks, dead battery again. Also, if I crank up the stereo, 4 10" subs, the lights will dim to a really low beam, lower then what I think is normal.

Does this sound like a bad alternator or bad battery? ANywbody know if the alternator squeels when it is almost dead or not?

Thanks

GAGTSCTGuy
08-03-2004, 05:42 PM
Alot of times, if I leave my ignition to on and I can even have the stereo turned down to "0", the battery will be dead in about 15 minutes like this.

That is quick for a battery to run down. Your battery will die if it is on for a long time but not running, but 15 minutes with nothing running sounds like a bigger problem, maybe a short or something.

If your battery dies and you jumpstart it, and then it holds that car, I would say it is probably not the alternator.

AutoZone tests alternators for free. So do many other large chain stores, along with batteries.

http://www1.autozone.com/servlet/UiBroker?ForwardPage=/az/in_our_stores/free_testing.jsp

kevin231
08-03-2004, 09:16 PM
bad ground for my amp caused that same problem for me

Kodeblue
08-04-2004, 03:19 PM
Well, I got the battery tested today and it tunrs out that is is no good. I pick up my new Optima Yellow Top tomorrow.