3.1 L help.. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 3.1 L help..


tranceokido
08-10-2004, 08:50 PM
This is not Pontiac related but I was hoping you guys maybe able to help. Some how on my 3.1L Corsica (same as the old GA's used) the vacume line from the FPR/TB to my MAP sensor became disconnected. Well I took of the intake maninfold since there was a kinked Vac line and I wanted to check the others. Well I ended up replacing some Vac lines and everything was okay till I got one clogged at a T fitting by pushing it to where the car couldn't get any vacume for that line. Well that was making the car run really really ****ty and throwing an SES light DTC 33. I was getting black smoke and everything bad. Well i found that was the problem and I fixed it and the car runs okay now without any SES. The only problem is my car won't downshift to the correct gear when I floor it. I only have a 3spd auto btw. 1st gear/45mph max (will only downshift to 1st if you are going under 35mph) 2nd /85mph (if your doing 80+ it won't **** to 2nd.) Well when I am driving at around 25mph and the car is in 3rd gear, if I floor it it will only go to about 43mph and then shift and then when its about to shift from 2-3 it will shift out at about 72mph. Now the 43mph from 45 doesn't bother me so much as the shifting at 72mph instead of the 85ish zone. Does anyone know what could be causing this? I went and bought a different MAP because I didn't know about the T fitting being clogged...so I am gonna try sticking the old MAP on to see if it makes a difference. Also since my car was running really ****ty and shooting out tuns of black smoke I may have messed up my plugs. I am gonna pull the plugs 2morrow and check. I was wondering if anyone knows what could be the problem. BTW..I even rested the PCM to see if that did anything but it did nothing. Thanx.

tranceokido
08-10-2004, 08:59 PM
Oh I forgot to say that about the 1st gear thing..It will only hold 1st gear till 43ish mph if I am doing it from a standstill. If I am driving 25 in 3rd gear the car will only downshift to 2nd and not 1st.

tranceokido
08-11-2004, 04:54 PM
bump?

tranceokido
08-12-2004, 11:35 AM
nobody can think of anything?

tranceokido
08-15-2004, 04:58 PM
Well I fixed it all by myself. The metal plate that had some throttle linkage connected to it was loose causing slack in the wire.... Good..that damn thing was ****in me off.