Hit 100,000 miles.... car breaks down [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Hit 100,000 miles.... car breaks down


nd4spd
09-03-2004, 06:18 PM
Well was getting off the x way, in rush hour, and I hit my first stop light. Starts to shake and stutter, then stalls. Sob! :scream: . Here comes the horns and fingers. Get it started, get to the next stop light, hear a loud humming noise, shakes badly, quits. So anyhow, I sit on the side of the road for about an hour. Start it up, and runs fine, and I make it home. Had a diag scanner check to see if its popping any codes.... none.... only thing I can think of is bad gas, but I filled up last week, no problems, maybe fuel filter, replaced a year ago. Its funny car has never left me stranded, and it still got me home. Course I do have the ol common LIM leak, just keep topping off the fluid every month. I have had a complete tune up about 15,000 miles ago, anything else you guys think I should do, just to be safe, I dont want this to happen again. Thanks for any help.

andrewe77
09-04-2004, 05:53 PM
If it's an automatic, I would look at the torque converter lockup solenoid. Should probably also have the fuel pump looked at.

coupe
09-04-2004, 06:22 PM
Its a commin problem and i seem to repeat myself lately but you might need to replace your TPS. Its cheap and easy. This might not be the problem since this is the worste ive ever heard it that bad. What makes me think it is this problem is you shut her down and started her back up and she ran fine. Commin.

rizer
09-05-2004, 02:47 AM
I just had my TPS replaced, costed 120 bucks all together w/ parts and labor.

Mine wouldnt stall though after/while driving, it would idle between 2k and 3500 in park and 1500 while in drive. Just sucked cause it'd slam into gear when going into drive. Not to menion the only car at a drive thru with exhaust roaring, heh

Though a few times, id start it in morning and it'd stall 1 second after or id almost have to give it gas when starting. That was rare though

nd4spd
09-05-2004, 11:28 AM
rizer i have had the same exact problems that you had with high idle, and shifting that gave me whiplash, but they were only twice, and I have not had that problem for a while. I know I should replace the tps, but maybe the fuel filter again, and yes have the fuel pump checked...

rizer
09-05-2004, 12:07 PM
Yeah, before it started doing it consistantly, it would really only do the idle thing after driving a hour or so. Then after a family death, i put almost 2k miles on my car in one week and that whole week it did it the whole time. So IMO, id take it in and have em check it out so thats less stress the tranny has to worry about for the momment :) Its gonna cost round 100 bucks like i said to have it replaced but if its gonna conserve the trannys life, its worth it

Never hurts to swap out fuel filter either, I usually do it once a year.