Problems upon problems.... Haha [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Problems upon problems.... Haha


Everclear
10-07-2004, 03:14 PM
So my engine started clanking at like 38 k miles .... i took it in to my dealership and they told me it had thrown a couple bearings and they scored the cylinder walls therefore it needed a new engine..... Luckly Gm said warrenty it.... but the thing is it was never raced and had no engine mods.... kinda luck for me it didnt go out any later....just thought i would share my story.

JetMtx
10-07-2004, 05:42 PM
Imagine how you'd feel if they told you they wouldn't warrenty it...

Turbodreams-se
10-18-2004, 01:38 PM
what engine does your car have everclear? Mine is having the same problem with only 10k on the engine... The engine was replaced for the same problem also. and it is a 2.4... If it happens one more time, my car is becoming a project ga/gtp mix with a 3800SC... I am sick and tired of it.

Turbodreams-se
10-29-2004, 06:04 PM
hmmm... after talking to the dealer, they are trying to blame my oil pressure gauge for the problem and void my warranty... I am pretty ****ed off about this. The engine was making the noise before I put the gauge in, and the oil has been changed once since then. I am sure if they noticed a leak when they changed my oil they would have said something, but you never know with Jiffy lube employees. On monday I am going in to speak with the service guy about this and let him know the situation. hopefully I can find my receipt from the oil change.and the one from the oil pressure gauge too, to prove it was in there before they changed the oil.

2002AmSE
11-01-2004, 09:09 AM
I've never heard of an engine go before 38k unless there was an oil pressure problem, old oil, or a LIM leak.

It makes me curious:
Was there ever a point where the car had discolored(not brown or black) or foamy oil? Has it gotten low on oil or the oil pressure light come on? What did you use for an oil change interval and with which type of oil?

twisted
11-06-2004, 11:11 PM
i had the same prob on my 02 3400 cyl 4 barring was shot but my car wasnt under warrenty so i just got a new engine