Security Question [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Security Question


kevin231
10-23-2004, 10:13 AM
I was driving on the highway one day and my security light came on. When i got to work i turned the car off and started it again, and it went away. This is my second time this has happend in the last year. It dosent seem to cause any problems or anything and rarley happens. Maybe once every 8 months. Should I be worried?

coupe
10-24-2004, 02:32 PM
Your lucky then. Mine comes on when i try to start my car and my car wont start for 10+ minutes after it comes on. Alot of the time it comes on after i stomp it when driving but dosent make my car stall or anything. Not to long ago it came on and stayed on for 3 months, i could still start my car but the light was always on. Now it went off an about twice a week it wont let me start my car. Do a search there is a few threads about this, none really that helpful.

kipster
10-24-2004, 04:39 PM
Hey man. Yeah my car is doing the exact same thing. Did it twice yesterday and once today. Getting pretty annoying actualy. Just another benefit of owning a GAGT i guess. I am gonna take it to the dealer this week sometime and hopefully they'll be able to figure it out. If anyone has any ideas on whats causing this, it sure would be nice to hear. thanx.

Malaclypse
10-24-2004, 11:25 PM
This is what the dealer will find. a B2960 in the BCM related to the passlock system. Basically you need a new passlock sensor which includes the lock cylinder and sensor. The lock cylinder needs to be re-keyed.

It shouldn't take more than an hour if they aren't busy.

coupe
10-25-2004, 03:19 PM
guestimate on what they might charge?

Malaclypse
10-25-2004, 10:18 PM
I heard in another post just a moment ago that it'll be ~$300.