High Idling speed [Archive] - GrandAmGT.com Forum

PDA

View Full Version : High Idling speed


mrjohnlim
11-11-2004, 07:37 PM
My 2000 Grand Am GT idles from 1000 to 1700 rpm when I start the ignition anywhere more than 7 hours since the car was last driven.
I have to press the brake pedal very forcefully just to keep the car stationary in drive, the rpm usually drops to normal levels of about 700 after staying stationary in drive for about 5 minutes or driving very delicately at low revs.
Sometimes, restarting the car helps to drop the rpm level.
There are moments after a long drive that the rpm suddenly rises very high too, typically the temp reads about 3/5 level on the gauge and when i stop and shift to neutral or park, the rpm goes even higher to about 1500 rpm.

What is the cause of this?
Any tweaking i can do to remedy this?
I attempted to have this checked out at the pontiac dealer but they simply said i have after market wiring and will cost a couple of hundred bucks just to investigate the problem.

Please help

mrjohnlim

magnanpi
11-11-2004, 10:55 PM
same thing happened to me the other day. i dont know why tho. it happened the other day. it was reving about 1500 in drive stopped and about 1900 in park or neutral. so i stopped. went all the way down to "1" then went back up to "D4" and it went away. i dont know y. it could have just been a coincidence. a couple other times it goes away by itself.

lol i was wondering y i let go of the gas pedal and was "coasting" and the car wasnt slowing down going uphill. it was actually speeding up. lol then it stopped revving so high and went back to the normal..

one time it happened and i let the the thing go. from a stop. and it sped up to 40 mph....by itself.

NorKoastal
11-12-2004, 12:04 PM
There was a TSB on this somewhere... They can re flash your PCM is anything is not current....

psychoticpnut
11-12-2004, 04:11 PM
I have kinda the same thing

If car hasent been on, it will idle at like 1700-1800 but only for like 20 seconds, has been doing this since i got it, i just assumed its warming up.
After that its at about 1100-1200 untill the cars temp gets up above 120 or so.
Then it idles at about 700 give or take a little.
would you say mine is normal, or the same TSB your refuring to as above?

GrahamKracka
11-12-2004, 04:44 PM
i idle at 600....something is def wrong with yours

NorKoastal
11-12-2004, 04:47 PM
Mine is the same they checked it (supposedly) nothing was wrong.. My car surges a lil at low rpm's when Im going up slight grades parking... When its cold it will idle high and slap around (normal I hear) Once warm for a minute or so shes a good to go..

DevilSlayer
11-12-2004, 06:31 PM
When I start my car in the morning it only goes up to 1000 RPM at idle and back down to 600-650 when the engine warms up.

mrjohnlim
11-15-2004, 04:36 PM
Pardon my ignorance but what's a TSB and PCM, where do i go to fix these issues?



There was a TSB on this somewhere... They can re flash your PCM is anything is not current....

MetaGTP1
11-15-2004, 04:41 PM
My 2000 Grand Am GT idles from 1000 to 1700 rpm when I start the ignition anywhere more than 7 hours since the car was last driven.
I have to press the brake pedal very forcefully just to keep the car stationary in drive, the rpm usually drops to normal levels of about 700 after staying stationary in drive for about 5 minutes or driving very delicately at low revs.
Sometimes, restarting the car helps to drop the rpm level.
There are moments after a long drive that the rpm suddenly rises very high too, typically the temp reads about 3/5 level on the gauge and when i stop and shift to neutral or park, the rpm goes even higher to about 1500 rpm.

What is the cause of this?
Any tweaking i can do to remedy this?
I attempted to have this checked out at the pontiac dealer but they simply said i have after market wiring and will cost a couple of hundred bucks just to investigate the problem.

Please help

mrjohnlimDid you receive an SES light? Other items to check, are the TPS and Idle Air Control sensor.

material_wishes
11-15-2004, 04:42 PM
i am having the same issue with my GT it idles at anywhere from 1300 to 1800 rpm and i guess thats normal since you guys have the same thing

coupe
11-15-2004, 04:51 PM
I dont think it has anything to do with the PCM

mrjohnlim
11-15-2004, 05:35 PM
Nope no warning light showed up, No SES light beeping.
Sorry to ask again but what's TPS?

MetaGTP1
11-15-2004, 07:33 PM
Nope no warning light showed up, No SES light beeping.
Sorry to ask again but what's TPS?TPS -Throttle Position Sensor.