Whiney steering wheel [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Whiney steering wheel


k-gun12
11-18-2004, 03:44 PM
2001 GAGT 26k miles.

My steering wheel has begun whining (not quite a squeak..) when turning. It's coming from in the dash somewhere, not from under the hood. Sounds like somebody is murdering a cat and is really embarrasing. Anybody else seen/heard this one before? Power steering fluid is OK.

GroundZero
11-18-2004, 03:59 PM
LOL it is the powersteering either the rack or the pump I have resealed my pump like 3 times so far and it finnaly went away try checking your p\s level if not do the pump if it isnt that then do the rack

carsarecool
11-18-2004, 04:32 PM
hm yeah mine does the exact same thing, most of my friends say "yo is there a chipmunk in your steering wheel?" or something like that, haha i have a 99 w/ the 2.4 but my power steering hasent leaked at all, i check it every few weeks, i even had a tech listen to it when he was test driving the car for something else, didnt seem like it was a big deal. been doin it since i got it, about 40,000 miles, hasnt changed, so

IanGT99
11-19-2004, 07:35 AM
Mine's always done that. It's really quiet and not so noticeable, but still there. I just figured that's how it was supposed to be...

Silentbob538
11-22-2004, 10:42 AM
I actually kinda like the noise...

Bouchie11982
11-22-2004, 11:04 AM
it def. ur powersteering...check your fluid too...my 94 ALWAYS did that...i sut got used to it cuz it was an old car LOL

NorKoastal
11-22-2004, 01:27 PM
Mine is leaking fluid out.... The fluid looks red and got all over my serpentine belt... After swapping the belt (replaced with cog style) smell and noise of the leaking fluid has been reduced.. I did hear a popping noise a week ago which resulted from a hard left u-turn I did (trying to fix another problem) Im going to get a new PS cap and check the hoses out.. Hopefully the rack isnt jacked up... I just lowered my car so the negative camber might have caused the pop... I have an extended warranty with a $200 deductable. Might have to reinstall stock stuff to not void the extended.....

brsexton
02-21-2005, 11:56 AM
Mine is doing this too, but it is not the PS pump or the rack. Its coming from some where in the column. It sounds like something needs to be lubed. Does anyone have a fix for this?

UNCTYPE-S
02-21-2005, 02:19 PM
is their a supercharger in there?