Car sluggish upon 1200-1900 RPM's [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car sluggish upon 1200-1900 RPM's


robert179
11-30-2004, 01:38 PM
My GASE 3.3L v6 is sluggish upon the first intial take off between 1200-1900RPMs.

It's not a air problem, must be a fuel prob. Anybody have a clue how or what this could be?

It also sounds like its going to stall out when it does that. Let me know any advice. :-)

Very much appreciated!

atc3434
11-30-2004, 02:17 PM
Fuel pump or clogged fuel filter. Stutters and bucks when you step on the pedal at low rpms right? I had a fuel pump go on my Buick Century, 3.3, acted real sluggish all over, but especially at the lower rpms.

robert179
11-30-2004, 02:31 PM
Fuel pump or clogged fuel filter. Stutters and bucks when you step on the pedal at low rpms right? I had a fuel pump go on my Buick Century, 3.3, acted real sluggish all over, but especially at the lower rpms.


Must be the fuel pump. Fuel filter was just replaced. :-( Correct. If I wanted to do an intial take off it's a no-no with this problem.

Fuel pump might be the problem... but if anyone else can give me some advice on any other problems... so I don't have to spend a few hundred to take it into the shop. :-)

Thanks again for the help/advice!
I'll look into the Fuel pump. :metal:

atc3434
11-30-2004, 02:37 PM
A shop should be able to test the fuel pressure for a small fee, and then you'll know if you've got trouble with the pump.

robert179
11-30-2004, 02:42 PM
Okay, I'll check into that. :-) Thanks for the advice! I just want to be able to get this thing running the way it should for a 93'.

:-)