Blower not working! PLeas ehelp [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Blower not working! PLeas ehelp


micchekka
12-16-2004, 06:39 AM
Ok, I need some help here! This morning I got in my GA and starting the heat, everything worked fine. I popped the hood and filled the coolant (with the car running and heat on). I got in the car and no heat! The A/C diddn't even work. No air is blowing out anymore? What could've happened?!?!?!

Slim
12-16-2004, 06:43 AM
It might be this.... (http://www.grandamgt.com/forum/showthread.php?t=1346&highlight=blower+resistor)

micchekka
12-16-2004, 06:44 AM
But it doesn't work on any speed???

MetaGTP1
12-16-2004, 06:50 AM
But it doesn't work on any speed???Does the blower motor work?

micchekka
12-16-2004, 06:51 AM
What do you mean? When I turn it to the different speeds, nothing works. Not even the defroster.

Slim
12-16-2004, 06:53 AM
Check the HVAC fuse then. Might be blown....

MetaGTP1
12-16-2004, 06:53 AM
What do you mean? When I turn it to the different speeds, nothing works. Not even the defroster.Do you hear the fan when you turn on the switch?

micchekka
12-16-2004, 06:56 AM
No, I don't hear the fan at all

MetaGTP1
12-16-2004, 07:05 AM
No, I don't hear the fan at allAs stated earlier, check the the fuse for the AC and the fan. If the fuses and/or relays are good, the blower motor may be bad. Check all fuses and/or relays related to the heater, AC, blower motor and HVAC controls first.

micchekka
12-16-2004, 07:07 AM
Any idea how much a blower goes for?

...and thanks for the help everyone.

MetaGTP1
12-16-2004, 07:08 AM
Any idea how much a blower goes for?

...and thanks for the help everyone.Try www.gmpartsdirect.com

micchekka
12-16-2004, 07:31 AM
Ok, I checked the fuses and they are all ok. How do I know if I should replace the blower motor or resistor?

MetaGTP1
12-16-2004, 08:04 AM
Ok, I checked the fuses and they are all ok. How do I know if I should replace the blower motor or resistor?Turn on the fan controls and listen near the blower motor. Do you hear a slight hum from the motor?

micchekka
12-16-2004, 08:08 AM
Nope, nothing at all. Dealer wants $106.00 for a blower motor. I just think its weird that it happened right after I filled the coolant. Guessing its the motor?

BTW, thanks for all your help KmanGT1

MetaGTP1
12-16-2004, 08:12 AM
Nope, nothing at all. Dealer wants $106.00 for a blower motor. I just think its weird that it happened right after I filled the coolant. Guessing its the motor?

BTW, thanks for all your help KmanGT1No problem. Sometimes things go in these cars, but you always get a warning of some sort. These warnings may be subtle and we think nothing of them(I'm guilty of that). :whistle:

MetaGTP1
12-16-2004, 08:19 AM
Nope, nothing at all. Dealer wants $106.00 for a blower motor. I just think its weird that it happened right after I filled the coolant. Guessing its the motor?

BTW, thanks for all your help KmanGT1Try replacing the blower motor resistor first and see if thats helps. :)

Violator
12-16-2004, 10:58 AM
I have a 93 and Im having the same prob almost. My motor works. At first only on high, but the fan didnt blow on high it felt more like out of 4 it felt 2. well after a few days it quit so I popped the hood and hit it and the motor kicked on, I though short so I took the connector wires off outside and sure enough there was corrosion, well I cleaned it all out and everything was bright and had a shine. But same prob, now if I shut if off thats it is off unless I hit it and the harder I hit it the faster it goes, but it never blows as if its on 4 it blows about 3.

Also on a different note I just installed a new radio and when taking out the mini glove box and stuff I noticed in the big box where I had some papers, it was wet with water. I was like what the heck, does anyone have a idea where it came from, I have noticed at one time that the passenger floor was damp, But I havent had a prob after I cleaned it. My drivers side get water there to but someone said that it could be the door (door drains are clogged), but weird thing is that I can hear the water when I drive (road noise) as I drive in the rain as if there was a hole or something but I hadnt found anything. no I do not have a sun roof, so its really bugging me.

micchekka
12-16-2004, 11:18 AM
I thought the blower motor was under the glove box where the resistor is? Are you saying it is under the hood?

Violator
12-16-2004, 12:30 PM
the case is that is how you change it on my model Im sure most models are the same the resistor is on the inside of the car.

Sorry for the confusion but 92-98 I think are on the outside of the car access to both motor and resister. The 99-03 have it on the inside of the car.

blazerk5drew
07-23-2007, 04:36 PM
my car had a similar problem except the blower motor was making a rumbling noise and it only worked on speeds 4 and 5 but they felt like they were working on 2 or 3.... it all stopped working one day so i put a resistor in and checked the fuses....still nothing....im prolly going to put a blower motor in and hope that fixes the problems...cuz an hvac contoller is like 200$