tranny problems [Archive] - GrandAmGT.com Forum

PDA

View Full Version : tranny problems


GTon9teens
12-16-2004, 10:24 AM
when i get up to speed, we'll say 30 mph and it shifts into overdrive, my tranny starts shifting back and forth when im trying to maintain a steady speed, other than that it runs just fine and only does it every now and then, could this be becaause of the brake light swithch like in the other thread? or is my tranny going out?

sicc
12-16-2004, 11:17 AM
There's a thread right under yours for the same exact thing.... http://www.grandamgt.com/forum/showthread.php?t=43997

eren00gt
12-16-2004, 02:34 PM
when i get up to speed, we'll say 30 mph and it shifts into overdrive, my tranny starts shifting back and forth when im trying to maintain a steady speed, other than that it runs just fine and only does it every now and then, could this be becaause of the brake light swithch like in the other thread? or is my tranny going out?


Try getting on the highway and turn on your cruise. If it shuts off by itself then yes you probably do have the brake light switch problem.

AznGA
12-16-2004, 05:11 PM
This seems like a common problem now.

GTon9teens
12-16-2004, 10:46 PM
my cruise control has been working just fine

Braves299
12-16-2004, 10:49 PM
mine does this too :( except mine does it mostly on the highway when i got the cruise set. when it switches gears, it sometimes gets confused and goes back and forth.... im scared

GTon9teens
12-17-2004, 10:16 AM
i guess the best thing to do would be to start by replacing my brake light switches and go from there, anyone have the part number

GTon9teens
01-12-2005, 01:13 AM
i had my tranny flushed yesterday, and problem is gone so far, bada bing

AznGA
01-12-2005, 01:35 AM
I also heard this is related to speed control sensor.