ABS Light & Trac Off Light again [Archive] - GrandAmGT.com Forum

PDA

View Full Version : ABS Light & Trac Off Light again


TheBigB11
12-16-2004, 03:05 PM
My last post was deleted for some reason. My ABS & Trac Off light comes on with a cold engine and stays on and with a warm engine it does not come on until I drive it for 5 minutes. The Service engine soon light is not on, the antilock brakes work when the light is off and don't when the light is on. Someone suggesed it is the wheel sensor.

Is there anyway to check and see if that is it?

Is the wheel sensor part of the Hub Assembly? I hooked up the OBDII reader and it did not show any codes.

sicc
12-16-2004, 03:13 PM
It deleted right as I was replying to it.. not sure why but I'm sure something screwed up. Anyway, It is most likely a wheel sensor. I had this problem randomly off and on for a while. Then one day when I replaced my bad wheel bearing, I found out the wheel sensor wires were completely cut. Never had the problem after that.

And yes it's all part of the wheel hub assembly. I believe I got it for $40 at autozone.

eaglesrealm
12-16-2004, 07:45 PM
Yes, it is almost 100% your wheel speed sensr, which is part of your wheel bearing assembly. You may be able to figure out which one it is by using a multimeter to ohm each sensor on all 4 wheels and see if one noticably stands out. Otherwise, have someone read your code and tell you which sensor failed.

I did this job a couple months ago and it fixed my Trac Off/ABS problem. The replacement from Autozone in Michigan cost me about $110.00 I believe.