ABS/Trac Off Light ON!!! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : ABS/Trac Off Light ON!!!


gagtrair985
12-21-2004, 03:53 PM
Here is a question for all you masters of mechanics in here. When i start my car everything is fine. When im going down the road and hit a bump at a given time...(turning for instance or railroad tracks) my ABS light and Trac Off light come on and it beeps a few times....But when i turn car off and turn it back on the lights are back off???

I had both hub assemblys in front replaced over a month ago, but i notice when i go over a bump i get some rattling noise in the front end. Not much but its there (and when i had everything apart everything seemed very solid and nothing was loose)...then eventually those lights came back on? and the process starts all over... any ideas?

scooby2
12-21-2004, 04:43 PM
My ABS light and Trac Off light came on during my drive home tonight. Please let it not be something else that needs money spent on.:-)

gagtrair985
12-21-2004, 05:58 PM
My ABS light and Trac Off light came on during my drive home tonight. Please let it not be something else that needs money spent on.:-)

I hear ya on that one. I just spent numerous bucks on rotors, hub assemblys, brake pads...only for something else to go wrong
ive noticed that my Low traction light comes on sometimes.... but i will still have traction seems like the engine slips or misfires not lose of traction ?? its hard to explain

mcgrady
12-21-2004, 07:08 PM
I would bet money on a slightly loose connection to one of your wheel speed sensors (bearings) that were just replaced. It gets jarred and loses the signal for a moment which turns on the service engine light but then the signal is ok when you restart the car and the light goes off.

2002GT
12-21-2004, 07:24 PM
wheel sensor... just replaced it

carsarecool
12-22-2004, 11:02 AM
can you get to the connection from under the car looking inside of the wheel (like when you change the oil)? or is it actually inside the bearing so you have to take the wheel and rotor off just to check if its loose?