Car Seems Sluggish... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Car Seems Sluggish...


xdiego16x
12-28-2004, 04:13 PM
My Grand Am seems extremely sluggish lately, so I put on a short ram intake on hoping to gain a little passing power. The intake made very little difference, and the car is still very sluggish. Here are the specs;
1997 Grand Am GT Sedan
2.4l I4
5-Speed manual transmission
78,xxx miles
Here is a 0-60 video, maybe someone can tell me if this is nomal acceleration.
http://www.mm2x.com/upload/files/IMG_0004.ASF
BTW- The check engine light is on due to the short ram intake

BiHStL
12-29-2004, 01:35 AM
why would the intake throw a code, mine never did

Anyways, try the easy, simple things first
spark plugs
wires
fuel filter
getting fuel injectors cleaned couldnt hurt

Bentley813
12-29-2004, 01:44 AM
hey your shift light is red, mine is orange.... lucky basta...

heh, I don't know if you're foot was to the floor but that did seem a little slow compared to mine.

xdiego16x
12-29-2004, 11:37 AM
Sadly, yes, it was to the floor ;psycho It seems to just stop accelerating after about 4,800 RPM's.

cals400ex
12-29-2004, 02:10 PM
i have 60K on my GT and i just changed plugs, wires, and my belt. the car runs much much better now. i didn't realize how much of a difference it would make. i did go with the expensive iridium plugs, taylor wires, and a gatorback belt. i am not sure if these aftermarket parts helped or the stock ones just needed replaced. also, replace the fuel filter if you haven't done that for a while. if that is dirty, it can feel like a new car when it is replaced. good luck