No apparent IAC action *new* [Archive] - GrandAmGT.com Forum

PDA

View Full Version : No apparent IAC action *new*


bigbangtech
01-02-2005, 10:03 PM
After having posted previously, I'm doing a repost with new information.

It doesn't appear that my IAC motor (Idle Air Control) is working on my 99 GASE w/3400 v6.

At normal operating temperature, engine idles at about 650rpm in Park.

Idles at 650rpm even if you place transmission in Drive or turn on AC full or turn steering wheel. (IAC should increase idle for any of these conditions)

When cold-starting engine, idles up to about 800rpm and goes down to 650rpm when fully warmed up. (IAC should increase idle to around 1100rpm to 1500rpm for about 30 to 60 seconds.) I'm guessing that it idles at 800rpm during cold start only due to increased fuel during cold-start, not due to IAC working.

I had access to a new IAC motor for free, so I replaced it. Same exact behavior.

I also removed the IAC, hooked it to the connector, turned key on, and it extends the pintle (tries to close IAC passage at key on). I have no idea if it tries to retract the pintle, because it will never bottom out with the IAC out of the throttle body. I also don't have a IAC test light to check for operation.

I gather that there are two coils in the IAC motor, one for pushing, one for pulling. I did not try to hook up a voltmeter to the IAC connector, too afraid to fry something in the PCM.

I'm wondering if I can rig a test lite of my own using LED's, or lamps to test the IAC wires coming from the PCM without damaging it. Any ideas?

I also ruled out an external vacuum leak ANYWHERE, having used the old propane trick, looking for an RPM increase.

Plus the SES light has never come on except during start-diagnostics.

bigbangtech
01-03-2005, 05:16 PM
I did some further testing and found that the IAC motor is working fine. I kept the new IAC motor in the throttle body, disconnected the wire and started the car. When it reached operating temperature, I conncted the old IAC motor to the harness, and tried turning the steering and turning on the AC. In each case, the pintle on the IAC retracted, and then extended.

So I know IAC is working both ways and the PCM and wiring is not damaged. But I'm still not getting a fast idle. At this point I was *reasonably* sure that there wasn't a vacuum leak after using propane to check for a speed increase,, but it might still be a possibility.

I also see a slight external LIM coolant leak. Has anyone ever had a vacuum leak in the LIM gasket?