Poor Acceleration Problem [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Poor Acceleration Problem


Mowat_1
01-03-2005, 07:21 AM
While driving car seems to hesitate (lurch) during normal acceleration. It feels like not fuel is not flowing properly or as if you continuously press and release gas pedal. Tach does not bounce stays normal. Is this a fuel pump, throttle body, or injector problem? Could it be poor gas or possible dirty fuel filter? No service lights have come on, at least not yet!

NorKoastal
01-03-2005, 11:58 AM
What have you replaced since getting the car????

Filters, Fluid, Parts ????

Mowat_1
01-03-2005, 01:09 PM
Throttle body, fuel enjectors cleaned about 1 year ago. Fuel filter replace 1 year ago. New spark plugs a year ago. New EGR valve about 6 months ago.

Malaclypse
01-03-2005, 01:21 PM
Put your foot to the floor. If the car doesn't go over 40 mph and seems to bog heavily your cat could be clogged. You'll also hear a loud pinging/ticking noise from under your hood.

Hodge
01-03-2005, 04:21 PM
Poor Acceleration: Welcome to the 2.4L 4 banger world! :thumbs:

carsarecool
01-03-2005, 04:39 PM
Poor Acceleration: Welcome to the 2.4L 4 banger world! :thumbs:

no kidding, haha dont even try to go anywhere with the A/C on

UNCTYPE-S
01-03-2005, 06:41 PM
tranny?

AaronGAGT
01-05-2005, 12:16 PM
tranny?

:homo:

Sounds like misfire problems

matthar924
01-09-2005, 07:52 PM
I had a similar issue about a year ago. Got in the car and it just didn't want to go very fast. Felt like the car was struggling. Got it to the mechanic and it was a bad #4 Injector. Haven't had any trouble like it since. It could be anything but a bad injector, but if it were an injector it'd throw a code.

96gase
02-01-2005, 10:01 PM
i put a k & n , new fuel filter, and new exhaust system and now shes as good as a stock GT... use good gas too that helps. and the best double platinums you can buy from ac delco. gm didn't design the 2.4L very good in terms of induction or exhaust a lot of performance can be gained there