brake prob's [Archive] - GrandAmGT.com Forum

PDA

View Full Version : brake prob's


tfrohliger
01-08-2005, 11:40 PM
when i first start out in my 95' the rear brakes both lock up. as i push on the pedal its like there is no brakes then all at once -BAM- rear brakes. and if i have much speed at all it kinda palses but not a fast palse. just grab-release-grab-release. after about 30sec. it stops most of the time. sometimes it will start doing it again while i'm driving. mainly when it is wet out but not always. sometimes the ABS light comes on and then it is fine. no more probs til the light goes off (useally after i turn the car off and back on).anybody seen this before? Know how to fix it? :flag:

badboy2451
01-08-2005, 11:44 PM
thats weird, when i used to own my '94, mine did that all the time too...same symptoms and everything

had it looked at but no1 found anything out of the ordinary...weirddd

tfrohliger
01-08-2005, 11:51 PM
i had it looked at too and they said the back pads were on backwords (like that when i got it) so i swaped them and its still doing it.

twisted
01-08-2005, 11:54 PM
thats not good man i would definaly get that looked at , dont want to be speedin and have no brakes all of a sudden :hang:
it sounds like either you caliper (if you got rear disks ) or you rabs system and if its your abs that will be expensive
my 94 s-10 had a similar prob and it was the abs
when the grage told me how much it was i almost :vomit:
thats when i got my ga just wasnt worth fixin :rolleyes:

tfrohliger
01-09-2005, 12:02 AM
do you know what was wrong with the abs?

twisted
01-09-2005, 12:38 AM
i never got that deep into it, would have cost more money, but from how i understand abs works it could have been a sensor or the abs controler or computer or what ever its called,
now you may be able to go to a junkyard and get the parts you need like computer if that is it if it is the sensors i would replae them new, i dont know all that much about brakes but that's the best anwser i can give you, id wait till more ppl reply because there are alot of smart ppl here and like i said it sounds like a issue i had but it may not be the same thing

tfrohliger
01-09-2005, 01:57 AM
can someone please help? i don't want to be killed in this car.