oh S%#$! grounded out the battery! help! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : oh S%#$! grounded out the battery! help!


carsarecool
01-19-2005, 06:24 PM
well i put an intake on this afternoon, for a 2.4 cavalier/GA, i relocated the IAT sensor, finished it up, went to start the car and it was fine- turned it off, shut and reopened the hood and when i went to start it, nothing happened- hood pushed it down a tad and the aluminum of the intake tubing touched the positive battery terminal, i pulled it off and tried to start but NOTHING happened :scream: just clicked, some lights flickered and my inside lights didnt come on. did i ruin the battery, blow a bunch of fuses, burn up the PCM, what happened? i cant really afford any more repairs- il go check the fuses hopefully thats all it is.

EDIT: yeah the inside lights come on and dash lights do, its like normal on "on" til i turn the key to start, then it flickers and clicks- also when i turn it COMPLETELY off and take the key out, the red "SECURITY" and battery indicator light are STILL on, as is the odometer- still checking fuses, the ones in the engine bay are mostly fine

Hexx
01-19-2005, 06:34 PM
do any dash lights come on? Take the battery out, get some jumper cables, hook them to the battery and use the other ends...touch them together to see if there are any sparks. If there is little or none, try recharging the battery or jump starting the car. If that is a no go still, check your fuses....you should know where they are at.

carsarecool
01-19-2005, 07:21 PM
update: fuses are fine, i checked all the PCM BCM and batt. fuses, their all good- although the BCM is clicking, like its trying to turn on and off or something, i took out the fuse for it and it stopped since it didnt sound too good- the dash lights come on when i turn the key back off, in the "on" or acc position i only get a dim SES light and air bag light, the fuel pump doesnt prime or anything. this sucks i hope i didnt fry the PCM, what could it be?!?

Hexx
01-19-2005, 08:22 PM
Did you try boosting the car? Do that or try another battery. If that doesnt work, you may have friend something but I doubt it.

carsarecool
01-19-2005, 08:38 PM
yeah tried jumping it, nothing, no power no clicking or anything- :doh: il get a new battery tomorrow

im worried it might have done something to the BCM or PCM cause of the clicking sound, although i know really low power can do weird sh!t to a car and make funny noises and stuff, my battery tie-down was loose too since i forgot to tighten it back down, i did that and the dash was still screwy but the headlights would come on very dim, etc- a buddy of mine said the batt. would probly freeze overnight, is it safe to try to jump that tomorrow? i just dont want acid going everywhere or anything.

intence
01-19-2005, 09:58 PM
What did you try jumping it with? I had a similar experience on my regal a few years ago, the battery just died, no sign of it being weak previously, but one afternoon at lunch I tried starting the car, and it wouldn't start. Gauges were jumping around, controls acting strange. Tried jumping it with a few other cars, but the old battery wasn't weak it was totally gone, no amount of boosting helped much. Most of the "donor" cars were smaller/weaker. A friend finally got it started using his Durango as the donor. Dropped a new battery in there and it was fine.

carsarecool
01-19-2005, 10:04 PM
hm must really be the battery then, my friend brought his moms 2003 ram 1500 over and we tried, a bunch of times but it didnt do anything- thats why im worried since when u usually jump a car the inside lights go on real dim and stuff but when we hooked up the good battery nothing changed


is there anything to do when installing the new batt., like pull any fuses or anything? or just hook up the neg and positive cables and bolt the tie-down

Malaclypse
01-20-2005, 12:20 AM
You could have burned up the fusible link going to the starter. It'll be a piece of wire smaller than the + cable going to the starter with heatshrink on both ends.

If you tug on opposite ends of the fusible link, it shouldn't stretch unless the wire inside has been burned.

carsarecool
01-20-2005, 02:37 PM
Update: Got a new battery from advance auto, installed it and still nothing, a lot of clicks coming from the fuse box in the engine bay, and the dash lights go crazy. One of my buddies said to check the voltage of the battery since they didnt charge it for me when i bought it- I got a multimeter and the new one was at 12.58 DC volts, i charged it to 13.2 but still nothing.

I'm guessing burned out PCM or BCM since those things will get messed up by just static electricity wont they?

How much do those run for repair?

action
01-21-2005, 08:29 AM
Check the fuseable link mentioned above.

carsarecool
01-21-2005, 04:57 PM
OK, well had it towed to the dealer today and told them what was goin on, turns out it was just corrosion on the inside of the rubber boot for the battery terminal ! i dunno why that would make it not start after it was already on- so they just cleaned the post and terminals up, it wasnt making a good connection on the metal plate that surrounds the part you screw in. The PCM is fine, the battery is fine, all the lights are back and it starts right up. Maybe they reset the powertrain control unit or something cause im not sure why it didnt start at all. Thanks for the help

videoman
01-21-2005, 08:31 PM
A freind had the same issue. He removed the battery, and pull the PCM, and two other Fuses. I think it was the right and left panel fuses. He then waited about 30 mins, connected the battery back up and reconnected the fuses and voila. Everything worked.