Hellllp! [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Hellllp!


TCP1984
01-21-2005, 12:18 PM
Ok guys this is driving me crazy i just got a new deh-p660 premier. Its hooked correctly ok well on of my mb quart tweeters came up hooked. So i took off the door panel and spliced wiring to extend the wires. Wells all of a sudden my system came alive or sumpin. All of my speakers just started having an excessive bass reaction they all started thumping. Not good for the quarts. so now i have a whining noise coming through the speakers, but only when they are wired through the amp. If I wire them stock straight from the head unit their is no whining noise. I replaced the rcas, that didnt help, and it whines with all three rca outlets in the back of the head unit. WHat is goin on?

Matt95GT
01-21-2005, 01:58 PM
Sounds like you damaged/fried the RCA preout grounds. I managed to do this once... temp amp setup in the trunk shifted while cornering, plug came out and landed on 12v line near distro/fuse block. Had to replace headunit. Ooops.

I've also pressed a headunit into the dash too hard once, not realizing there was not enough depth with the bundle of wires. The RCA plugs were pressed so hard, the PCB inside the headunit cracked where the RCA socket ground is soldered to the board. I had to open the headunit and solder a wire to bypass the broken ground trace.

If you have one, use an adapter or cable to hook up a battery-powered portable CD player, MP3 player, walkman, etc directly into the amp. (Remember to turn the volume down on it, since it'll control the volume level) See if you get the noise then.
Noise = amp or it's wiring
No noise = headunit

TCP1984
02-01-2005, 10:51 PM
thanks