Weird power steering problem... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Weird power steering problem...


LukeD
02-19-2005, 02:17 PM
It happens only when I am making a hard turn while going pretty fast. There is a twisty abandoned road I sometimes take my car to try it out rally style. Anyway sometimes if I take a hard turn it will feel like I have lost power steering and the steering wheel will refuse to turn any further and only until I brake will it feed power steering fluid back into it or whatever it does. This happens sometimes on offramps too. I never have a problem at lower speeds though. Any ideas? Maybe air in the power steering lines? Broken power steering pump? Wasnt there something built into the GA that gave you less power steering at higher speeds? But if that was the case my wheel shouldnt lock right?

99GApunk
02-19-2005, 04:18 PM
maybe youre sliding? just dont go so fast

LukeD
02-19-2005, 04:28 PM
Nah I'd know if I was sliding. Plus the traction light doesnt come on. And it's not like I'm going breakneck speeds it's just more aggressive than your common corner turn around the block.

It's like it locks up in the 2 o'clock position (starting from 12 going straight). Really unnatural feeling, I let someone else drive it and it happened to him too so it's not just my driving.

LukeD
02-22-2005, 07:38 PM
Any other ideas?

Red99SE
02-23-2005, 11:03 AM
My Se does this as well. Not at high speeds or "spirited" driving. Just normal day to day driving. Sometimes around a long turn, I wil notice the wheel lock for a second and feel like it won't turn any further. I just push a little more and it seems to "release" for lack of a better word. I just figured it was due to an electronic pump or something. Never looked into any real reason why.

tenspeed
02-23-2005, 11:22 AM
Sounds like the rack is worn out.

Joker694
02-23-2005, 01:36 PM
grand ams have variable assist steering so you get more power assist at slower speeds like parking lots and less assist at faster speeds. If your power steering pump was broken you would have no power assist at all.

LukeD
02-23-2005, 06:05 PM
My Se does this as well. Not at high speeds or "spirited" driving. Just normal day to day driving. Sometimes around a long turn, I wil notice the wheel lock for a second and feel like it won't turn any further. I just push a little more and it seems to "release" for lack of a better word. I just figured it was due to an electronic pump or something. Never looked into any real reason why.

YES that exactly describes it.

Sounds like the rack is worn out.

How would I be able to tell?

ryanbgb22
01-21-2007, 09:27 PM
today i was doing reverse doughnuts in a parking lot (friends dad's business, not illegally lol) and after i finished i totally lost powersteering. After sitting there for a minute i started driving and i had powersteering. After stopping and sitting in one place i tried turning the wheel from left to right and it was really hard, however, if i put it in neutral and gave it gas it would steer fine.

I've gotta drive to ohio on friday, i need help fast!!!
thanks

gectek
01-22-2007, 12:08 AM
some of the steering problems are because of worn upper mounts on the struts, because thats is where the knuckle pivots, it take a good look at those also