oxygen sensor [Archive] - GrandAmGT.com Forum

PDA

View Full Version : oxygen sensor


sinnahjay
03-01-2005, 02:35 PM
Does anyone know if a bad o2 sensor would cause your car to idle like it has a misfire? I changed my spark plugs a couple of weeks ago and the car was running fine. A couple of days ago it seemed like my car was misfiring while idling and my SES light was on but it didn't show a cylinder misfire, instead, it showed a P0141 code for an O2 sensor. If I replace the O2 sensor, would the idle return to normal or should I get it checked by a mechanic? Also, someone told me I might have a bad valve but that's more stress I don't need. Any suggestions, please let me know.

Bentley813
03-01-2005, 02:47 PM
funny, I'm having the same exact problem. I think it's the o2 sensor by the cat.

atc3434
03-01-2005, 03:28 PM
IF the car's throwing a light for an O2 sensor, you should get that replaced. That could cause you to have a screwy idle, as well as possible bad fuel ecconomy. I'm not sure which sensor is bad. There are two, one is behind the engine, after the two manifolds are joined. The other sensor is below the car, after the catalytic converter. The sensor would be less likely to cause your funny idle, its purpose is to montior the emissions after the cat. I searched that code, couldn't find anything saying which is which. Hope that helps some.

tenspeed
03-01-2005, 06:45 PM
Does anyone know if a bad o2 sensor would cause your car to idle like it has a misfire? I changed my spark plugs a couple of weeks ago and the car was running fine.

I don't think a bad O2 sensor would cause a misfire. It would turn on the cooling fan, run rich and throw a SES light.

A bad spark plug will give you a rough idle and throw a O2 code because of the unburnt gasses heading down the pipe. What kind of plugs did you install?

H.O. Driver
03-01-2005, 06:53 PM
Check your coils, see if they are rusted, if you are over 100k it might be time for some new wires. Dirty MAF could cuz the rough idle too.

sinnahjay
03-04-2005, 10:18 AM
I don't think a bad O2 sensor would cause a misfire. It would turn on the cooling fan, run rich and throw a SES light.

A bad spark plug will give you a rough idle and throw a O2 code because of the unburnt gasses heading down the pipe. What kind of plugs did you install?


I'm not sure what kind of spark plugs I used but I've heard some things about using certain spark plugs instead of others. Any suggestions? I did change my wires when I changed my spark plugs but I haven't checked the MAF.