SECURITY!...what the? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : SECURITY!...what the?


cad_99gt316
03-09-2005, 09:00 PM
when i got in the car this morn, i turned the ignition on, and attempted to start the car. it didnt. after i cut the ignition back off, this dumb ass "SECURITY" light in the dash starts blinking. this has happened to me before. after about 10-20 min the "SECURITY" light turns off and i can start the car. i dont have an alarm, just keyless entry. what the hell caused this?

Panacea
03-10-2005, 02:38 AM
It's possible your ignition cylinder is going bad. Not positive that's the problem, but that's what went wrong on my cousins, and also a girl I work with.

sluggerx5
03-10-2005, 05:31 AM
when i remote start my car and then when i get inside and turn the key to on the security light comes on. i was also wondering why it does that cause i know i have security. It doesn't need to tell me that. Oh well i guess its not that big of a deal.

Joker694
03-10-2005, 06:20 AM
your security system will kick in if your ignition is tampered with or your car thinks that it is being tampered with. when I try to remote start my car when its really cold out it doesnt always work and that sets off the security system. you have to put your key in the on position and wait 10 minutes and then it should turn off. if you still have problems with the light going off talk to whoever installed your remote starter

sc02grandam
03-10-2005, 11:10 AM
your security system will kick in if your ignition is tampered with or your car thinks that it is being tampered with. when I try to remote start my car when its really cold out it doesnt always work and that sets off the security system. you have to put your key in the on position and wait 10 minutes and then it should turn off. if you still have problems with the light going off talk to whoever installed your remote starter

he doesnt have a starter.. reason why your car wont start when its really cold is whoever installed your starter used either a cheap passlock bypass module or didnt put it on the proper resistance

and to answer the question above.. either your key is messed up or your ignition cylinder is going

cad_99gt316
03-10-2005, 09:36 PM
hmm.... ok, that could explain somethings. so it could be the starter, the ignition cylinder, or a worn out key. right? heres another one for yall: one day i was driving down the freeway just cruisin. then the "SECURITY" light turned on. nothin happened. the car didnt shut off, it didnt do anything wierd. about a mile later, the light went off. damn GM...

Panacea
03-11-2005, 02:09 AM
Take it to the dealer. Worse case you could have a wet BCM. Do you have a sunroof? Anyway, best bet is to take to to the dealer. They can read codes and do some tests and give you a better answer than we will be able to produce. All we are doing is blindly guessing as to what we think it could be.

cad_99gt316
03-14-2005, 09:30 PM
yeah, i do have a sunroof. hmm, interesting.

reeotch31
04-02-2005, 10:25 AM
how much would a new ignition cylinder cost.....roughly? Why would a sunroof cause the security light to come on?

digitalballz
04-03-2005, 01:52 PM
mine does this also. Its a total pain in the a$$. Mines been doin it since I got my car. oh well...

Jesse99Gt
04-03-2005, 07:15 PM
that **** just happend to me today the security light came on the car wouldnt start it really suck

70 BOWTIE
04-03-2005, 07:47 PM
I was pricing the ign.cyl. about a month ago,r u sitting down mine was $270. the switch is only $45. I got a used cyl at a salavge yard they gave me the whole setup for $45.This was on a 97 G-A I put the cyl and switch in and it threw the THEFT system on.Had to have computer reprogramed to get it to start.

2002AmSE
04-03-2005, 10:34 PM
This sort of thread comes up from time to time, its usually the ignition cylinder that is the culprit from what i've read.

Personally, I have had the following happen:
I was driving down the highway one day and the security light comes on, I immediately hit the "Pontiac Dealer" phone listing in my phone book because i've read threads and was worried that my car might not turn back on the next time I would try, the service manager said that it 'could' but it won't usually.
Well, it didn't right away. A month later after I walked out of a job interview feeling great about how things went I got in the car and it wouldn't start because the security light was blinking, so I waited the 15 mins until the light went solid and I think I had to flip it to ACC then it would start or something like that.
It was fine after that until a week later when I was driving my friend around looking for something to do on a saturday, we stopped at a pet store to go play with the little dogs and the birds, when we were done with that the security light came on and it would start, same as before.
Then later that day it happened again, and it hasn't happened since. It has been almost a year now.

I suppose I'm lucky. Our keys don't have microchips in them or anything so the car doesn't know if the key is identical to the key that should be in there, just as long as its cut it turns the lock, and the car's "security" only detects to see if a key is actually in the ignition or not.

I don't know if this would do anything but it's worth a shot, it is something I would do if the problem arose again. I would wipe the key off by rubbing it with my shirt or other clean dry cloth and insert the key, wiggle it around a little and do that a few times to ensure that the key and the cylinder are dry and clean with no oil or anything. It's a hunch to me that maybe it was a problem with the 'electrical connection' with the key in there, but it would be just a shot. Maybe wiping the key down with some rubbing alcohol, as long as the key is completly dry(don't want to fry anything in the ignition).