I Think ive solved my missfire/engine stutter isue [Archive] - GrandAmGT.com Forum

PDA

View Full Version : I Think ive solved my missfire/engine stutter isue


Rba007
04-23-2005, 08:25 PM
I decided to start small and cheap today, and replace my spark plugs...

Now, last year when I installed my ignition (dont remember the brand, its the popular DIS system...) I also installed some new spark plug insulators from RK-Sport.

http://www.rksport.com/image?product_id=02099100&size=mid


When I removed enough parts to look at the plug boots, it looked like someone had sprayed expanding foam in there. Id say that the RKSport inserts cant handle the added heat from an aftermarket ignition system. They literally gelled all up, causing damage to the plug boots (i had to pull them out in small peices with needle-nose pliers).

So, im ****ed about that. What really sucks, is that now im stuck at home till a GM dealership opens up so that I can get replacement parts (the springs, boots and the platic thingies that the boots go in, 2.4 owners will be familiar with this), I doubt Autozone carries all of that, But ill definitely check tomorrow.

Anyway, thought id throw out the warning to fellow 2.4 owners. Steer clear of those stupid insulators from RKSPORT!!!

atc3434
04-23-2005, 08:29 PM
You ought to drop RK a line and tell them they got a bad part on their hands. Maybe they'd spring for new wires . (doubtful) Cool that you seemingly have solved the problem.

Rba007
04-23-2005, 08:32 PM
Since i wont be able to get her running till I replace the parts that crumbled as soon as I tried to yank them out, Im just assuming itll fix the issue. It was certainly messed up enough in there I would imagine it will take care of the issue. I will email them and see what they have to say.