2.4 Sudden Power Loss, With Trac Off Light [Archive] - GrandAmGT.com Forum

PDA

View Full Version : 2.4 Sudden Power Loss, With Trac Off Light


Rba007
04-30-2005, 08:16 AM
Occasionally when accelerating with atleast 2/3 throttle, the car will hesitate badly prior to the 1-2 upshift. When this happens, my trac off light also breifly flashes.

I have no SES/SVS codes or lights. I recently changed the spark plugs thinking that it may be some sort of a miss.

I idle a lot better than it used to thanks to the new plugs, but this hesitation is startin to bug me. Any thoughts? Wonder what would trip that Trac Off light?

-Dave

Molson
04-30-2005, 08:20 AM
FWIW, the IAT disconnected trips the Trac Off.

Rba007
04-30-2005, 10:05 AM
Its in there good.... Stupid machine.

Molson
04-30-2005, 11:28 AM
But is it working?

Rba007
04-30-2005, 01:45 PM
How could i determine that?

urweak
04-30-2005, 02:58 PM
well you car is modded, what is all done, did you have an EGR or do you have one now?

Rba007
04-30-2005, 03:03 PM
Nope, my year doesnt have the EGR. I basically have headers, intake manifold, new TB, and ignition done with the engine.

urweak
04-30-2005, 03:15 PM
i think its a common 2.4 problem, i have it and i know alot of other people that do too, and i cant figure it out. I replaced all the stuff under my IDI cover and that helped for awhile, maybe try that, get a used one off ebay, or buy new one whichever and try that.

Rba007
04-30-2005, 03:21 PM
I got a new one about a year ago... Changed the plugs last week. ****es me off. Had a hottie in a 2.4 alero try to get a jump on me in traffic a few days ago... She didnt. But i felt like a moron while my car decided to slow down all on its own so i could have another look at the chica. I guess it wasnt all that bad. BUT, thats the only time that its done that involving a hot woman, so its usually not a good thing.

urweak
04-30-2005, 03:26 PM
although when i had my HO manifold on the car it never happened, but once i put it back to stock over the winter it came back. so ive kinda always though it was the EGR, ive heard it might be the cat, and i do have a check engine light for my cat, so somtime this summer im going to replace that and see what happens.