loose sounds from up front [Archive] - GrandAmGT.com Forum

PDA

View Full Version : loose sounds from up front


rckrzy1
05-23-2005, 09:49 AM
Is there any thing to look for when you GA sounds like the front suspension is loose, I mean pot holes cause sounds like some bushings or something is worn out. It's 2000SE with 90K.

NorKoastal
05-23-2005, 10:10 AM
Good question.. We need a clunking thread... What wears most on our front suspensions and how to fix tham... What bushings/parts are more wearable than others?

I have KYB's so Im doomed anyways but there are some little rattles that might be able to be fixed with a replacement... (Ball joints, tie rods, sway bar bushing's etc)

Thanks.

AaronGAGT
05-23-2005, 12:13 PM
Make sure your calipers are tightened. A lot of people (including myself) have experienced the bolts working themselves loose. In my case, a bolt actually fell completely out and my caliper just rested on the rotor and I sounded like a freight train.

Just a thought.

AznGA
05-23-2005, 04:02 PM
Good question.. We need a clunking thread... What wears most on our front suspensions and how to fix tham... What bushings/parts are more wearable than others?

I have KYB's so Im doomed anyways but there are some little rattles that might be able to be fixed with a replacement... (Ball joints, tie rods, sway bar bushing's etc)

Thanks.
How are those washers for KYB's doing?

93 GT
05-24-2005, 01:46 AM
Ball joints, tie rods, sway bar bushing's etc

and don`t forget the strut mounting plates . When one of them go bye bye you get you`r self a strut bolt through the hood and a very bad ride .

NorKoastal
05-24-2005, 08:15 AM
How are those washers for KYB's doing?

Noisy... They clank on decent bumps... I cant wait for the new KYB's to get released.

AznGA
05-24-2005, 11:02 AM
Noisy... They clank on decent bumps... I cant wait for the new KYB's to get released.
You have 1/2" thick washer in there right? That should fix it. I dunno why yours still clunk.

NorKoastal
05-24-2005, 11:35 AM
2 washers that hit each other... 1/8 inch tall each..

rckrzy1
05-24-2005, 11:46 AM
You guys have done a good job hijacking my thread.

Nirbush
05-24-2005, 12:04 PM
mine does the same but only when i pull in and out of my driveway i hear a weird clinking in right front spring area.

93 GT
05-24-2005, 12:10 PM
You`r best bet will prolly be to bring it to a shop and have them check it out for ya .

SilverGAGT04
05-24-2005, 06:12 PM
A clunk in the front end is usually a bad strut mount and seat. This is what 90% of the cars I fix need for a clunk in the front GA's don't eat up b.j.'s. Tie rods that are bad cause a high speed shimmy and a clunk when turning back and forth fast. Swaybar endlinks make a clunk over bumps. This is a general description.

AznGA
05-24-2005, 07:08 PM
You guys have done a good job hijacking my thread.
Hey, we are just trying to help. Maybe you should claify what your problem is.
:rolleyes:

AznGA
05-24-2005, 07:10 PM
A clunk in the front end is usually a bad strut mount and seat. This is what 90% of the cars I fix need for a clunk in the front GA's don't eat up b.j.'s. Tie rods that are bad cause a high speed shimmy and a clunk when turning back and forth fast. Swaybar endlinks make a clunk over bumps. This is a general description.
The clunk issue with KYB struts is different. The nuts that KYB provides isn't as thick as the stock ones causing it to not tighten enough.

2003SCT
05-26-2005, 11:27 AM
Hey guys....I am gonna be installing the KYBs and Eibachs this next week and I don't want to have the clunk issue so here's a couple of questions:

1: Which are the better strut mounts to use..the KYB ones or the GM ones?

2: D you need to do 4 new strut mounts or just the two in front?

3: As far as the washer thing goes...are they coming with proper washers now so they dont clunk OR are these washers something I can buy somewhere or use old ones or what??? I dont want the clunk...wanna do it right and forget it.


CHRIS

NorKoastal
05-26-2005, 01:12 PM
The two in the front are the most important... The back two are less trouble and wear slower.. The front mounts turns when you steer so they are more prone to wear out..

Im not sure about the mounts quality... Gabriel also makes replacements for us to..

NorKoastal
05-26-2005, 01:22 PM
A clunk in the front end is usually a bad strut mount and seat. This is what 90% of the cars I fix need for a clunk in the front GA's don't eat up b.j.'s. Tie rods that are bad cause a high speed shimmy and a clunk when turning back and forth fast. Swaybar endlinks make a clunk over bumps. This is a general description.

I am going to stuff rubber inbetween my mounts and the strut tower... If that doesnt cure the noise I guess the Swaybar Endlinks might be the culprit....

Any replacement suggestions?? OEM or aftermarket ?

My car (steering wheel) doesnt shimmy until I get to around 80 so the Tie Rods sound like they are still good.

Thanks,

AznGA
05-26-2005, 03:49 PM
Hey guys....I am gonna be installing the KYBs and Eibachs this next week and I don't want to have the clunk issue so here's a couple of questions:

1: Which are the better strut mounts to use..the KYB ones or the GM ones?

2: D you need to do 4 new strut mounts or just the two in front?

3: As far as the washer thing goes...are they coming with proper washers now so they dont clunk OR are these washers something I can buy somewhere or use old ones or what??? I dont want the clunk...wanna do it right and forget it.


CHRIS
Take a look at the nuts KYB comes with. You have to use it because stock struts and KYB's are threaded differently. Go get a thick 1/2" washer that can go underneath the nut.

RODAN
06-08-2005, 05:23 PM
So with Kyb struts and Kyb mounts you do not use the 1/2" washer?
With Kyb strut and OEM mount you use 1/2" washer. Right or wrong.

GTwannabe
06-09-2005, 02:13 AM
I too have the same clunking noise more noticeable at passenger side -took it to pep boys-they said it was worn eng mounts. they were worn out alrite but that didn't fix the noise-so i replaced all struts/ frt strut mounts, both lower control arms/ball jnts ,sw/br links as well as new calipers too. tie rods feel ok /cv shafts feel pretty tight too ,but it still clunks too- so I just crank up the radio a notch -that helps with that dirty turn sig contact!

RaGePsYch0
06-09-2005, 10:27 AM
i had a noise too, with my KYB and Eibach setup, and to fix it, i wrapped the top coil of the springs with a thin rubber hose, that stopped all noises, so i dont know what was causin it, but it may be worth a try to some people. :)