Code P0440, won't go away [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Code P0440, won't go away


jesse_c82
07-17-2005, 12:54 AM
Ok, I had my SES light come on and it read P0440 evaporative emission control malfunction. I read the posts here and most of them said it was most likely the gas cap. Well I changed my gas cap and the pcv valve (why not, it was 3 bucks) and had a freicnd of mine clear the code. Two days later and it comses back and I'm out of ideas. I have the repair manual and it says check the hoses and says the diagram is on the radiator support but I don't see it. Any suggestion to what elseit might be, if not the hoses I'll check the EVAP canistor next, but I"m stuck here guys.



next time please use a different title than "need help" or your thread will probably end up in the trash, thanks

robc7gt
07-18-2005, 09:49 PM
gas cap bad

kubiache
07-19-2005, 03:10 AM
gas cap bad

Or broken evap line/port on fuel pump. Or leaking fuel pump o-ring, etc. If a gas cap is cheap, you might as well replace it to rule that out, but and EVAP code CAN actually be more than a gas cap being too lose.

jesse_c82
07-20-2005, 12:14 PM
I already replaced the gas cap, that's why I posted this, I need help guys.

jesse_c82
07-20-2005, 01:27 PM
Does anyone know where the diagram for the EVAP hoses is, my repair manual says it's on the radiotor support but I can't find it.

kubiache
07-20-2005, 03:27 PM
I already replaced the gas cap, that's why I posted this, I need help guys.
...

Or broken evap line/port on fuel pump. Or leaking fuel pump o-ring, etc

robc7gt
07-27-2005, 09:57 AM
check the EVAP canister it is right next to fuel filter!

LostTime
05-19-2006, 01:11 PM
i'm getting the same code, as well as a p0128

Things i've seen that might add to this:
I can't top off my gas tank. When i go to top if off it will over flow, does not cut-off. The over flow is out of the top of the gas tank. I think the Over flow value might be broken, and doesn't seal. I'm guessing that means i'm gonna need to drop my gas tank and fix it from there...

The 128 seems to be a themostat problem. I've noticed that my Engine Temp gague will stop working from time to time, I'm not sure if it's a bad sensor or just a wiring issue. Someone also told me it might mean the themostat is stuck open.

Can nay more prep me with the Cost of getting these fixed in a shop?
I don't want to go walking into a shop and expecting a $300 and them droping me with a $893 bill, and holding my car till i can afford bail.

Or The amount of Work behind droping hte gas tank and replacing to sensor.

lvemy3100
05-19-2006, 01:20 PM
same thing happend to me .. got the code and replaced the cap.... still a light... next time I went to fill up I put a little saliva on the seal for the cap and 2 days later the light turned off....

dont know what was going on but it hasnt thrown that code since i did that and so everytime I fill up now I just smear a little on with my finger in hopes to prevent this from happening again.

digitalballz
05-19-2006, 05:49 PM
evap codes suck!!

lvemy3100
05-23-2006, 07:46 AM
after some reading on gm's site it seems that some cars had issues with throwing codes for no real reason and there have been corrections made to some of the updated PCM files that will possibly get rid of "false" codes and stop them from being thrown

HTH