hesitaion part 2 [Archive] - GrandAmGT.com Forum

PDA

View Full Version : hesitaion part 2


apl111
07-03-2005, 09:21 AM
I am looking for suggestions as to what to look for. My car is a 99 GT with 75k miles. I noticed that when I drive on the highway sometimes at a very light acceleration the car will start to surge or buck. The rpms will bounce between 2 - 3k. It will go away if I give it more gas. What I am looking for is suggestions for what to look for. It has new plugs and wires. the fuel filter was replaced at abou 50k. The computer has not thrown any codes. I recently replaced the battery and alternator. Thanks.
:iconfused

mcgrady
07-03-2005, 09:34 AM
When is the last time you've had a fuel injection cleaning?

apl111
07-03-2005, 09:38 AM
never I am thinking this may be the problem. Thing is it has done this for a long time and now it may be getting worse.

GAGTnut38
07-03-2005, 10:16 AM
i have noticed that anytime i accelerate from a stop that if i am in the area of 2500 rpm the entire drive assembly starts jumpin and makin some sick pounding noises like it wants to get out of my car . that will **** ya off

brsexton
07-07-2005, 05:23 PM
I am looking for suggestions as to what to look for. My car is a 99 GT with 75k miles. I noticed that when I drive on the highway sometimes at a very light acceleration the car will start to surge or buck. The rpms will bounce between 2 - 3k. It will go away if I give it more gas. What I am looking for is suggestions for what to look for. It has new plugs and wires. the fuel filter was replaced at abou 50k. The computer has not thrown any codes. I recently replaced the battery and alternator. Thanks.
:iconfused


Just wondering if you ever had your car checked? I have an 03 Alero Ecotec 40k miles that is doing almost the same. It "bucks" or misfires while driving on the highway and giving it a little bit of gas. If I press the gas harder, it clears up. I can't see it in my Tach though. I have NO codes either. I have replaced my plugs, fuel filter and air filter with no help. I found a tsb about GM's and dirty injectors. Just hoping thats it before I spend $100 for this service...

AaronGAGT
07-07-2005, 05:54 PM
Subtle misfires will not cause SES lights. Only when its really bad is when the light comes on, sometimes blinking.

Plugs, wires, fuel delivery system (injectors, filter, pump might be peacin out) is where the problem probably is.

brsexton
07-08-2005, 02:27 PM
Subtle misfires will not cause SES lights. Only when its really bad is when the light comes on, sometimes blinking.

Plugs, wires, fuel delivery system (injectors, filter, pump might be peacin out) is where the problem probably is.


Exactly...Your SES light don't have to be on for something to be wrong with your car. I wish dealers felt this way. I am scared to take mine in because most don't think anything is wrong because the freaking SES light is not on. If they would just check a little deeper, they may find these problems.

apl111
07-20-2005, 08:22 AM
OKay here is the deal I originally posted that my car has a hesitaion problem along with very bad gas mileage. I just had the fuel injectors cleaned. Now my gas mileage on the highway is 30 mpg seems to be better. Here is the weird part. The car does not do this with the cruise control on. With cruise on there is no hesitation. What happens is as I am driving on the highway at light throttle I get a hesitation. The tach will bump up and down by 500 rpm. This will happen a couple of times and then go away by itself, or it will go away if I give the car more gas. Yet as I said with cruise on I never see this problem. All I can think to look at is the IAc but I dont think this is the problem. Its got new plugs and wires about a yrear old. Thanks in advance.

freakydeaky
07-20-2005, 08:51 AM
how's the fuel pressure?..... possibly EGR valve or the mass airflow sensor, do you have the MAF screen removed?

apl111
07-20-2005, 10:06 AM
Everything is stock on the car except for a slp exhaust and a WAI.

AleroME
07-20-2005, 02:32 PM
trying cleaning your MAF sensor .. It helped my car when it was hesitating to accelerate sometimes. After cleaning it, It was awesome. engine ran like new again.

AznGA
07-20-2005, 02:53 PM
RPM jumping up and down at shiftpoints? Does the car finally shift if you give more gas? I had this problem and it went away after transmission flush. When the tranny fluid is old, the particles inside it make the tranny stick.

NorKoastal
07-20-2005, 03:53 PM
How about the 24X sensor??? might be going bad or its dirty...... The reluctor ring might be giving a goofy reading.. Under 3K it is still used.,...

apl111
07-21-2005, 05:46 AM
What do I use to clean the MAF sensor. It does not shift when this happens. I think it is less noticeable now that I had the injectors cleaned. On a side note is it possible to test the MAF sensor. I saw a tester on ebay for sale.

ATL99GT
07-22-2005, 10:34 AM
You can use one of those compressed air bottles and gently blow through it and over all the pieces... but BE CAREFUL as to not actually touch the wired in the MAF or your car will be f*#&$ed

apl111
07-22-2005, 12:56 PM
Well I used a spray on electronic circuit cleaner.Car seems to run okay now. At this point all I can replace is the PCV valve, which still rattles so it should be okay. The O2 sensor is still the same as what came with the car. I do not think it needs to be replaced as the computer doesnt seem to be throwing any codes, at least my check engine light is not on.

Exodus
07-22-2005, 01:13 PM
its definitly a grand am thing mine does this too, mostly during warm temps

CyberianHusky
07-24-2005, 02:46 PM
Absolutely keep your MAF sensors clean. I had the same surging problems after I installed my CAI. I finally opened up the sensor and saw all kinds of black build up. I guess I kicked up some dirt from my lower facia when I did the install. A quick cleaning solved everything.

apl111
07-25-2005, 06:45 AM
Well here is the update on my car. Cleaned the fuel injectors, cleaned MAF. Car does not appear to be hesitating. On the highway I got 30 mpg in the city got 20 mpg.

brsexton
07-25-2005, 01:34 PM
Well here is the update on my car. Cleaned the fuel injectors, cleaned MAF. Car does not appear to be hesitating. On the highway I got 30 mpg in the city got 20 mpg.


Glad to hear it. Did you have the injectors cleaned by the dealer?

apl111
07-26-2005, 05:43 AM
Yes the dealer did it for 99.00 bucks it was a pressurized top down engine cleaner. Before when I drove around it was like I had a hole in the gas tank. The mileage is not great now but I can live with it. Car feels like it has a lot more power, probably cause I am not flooring it thru dirty injectors. I didnt want to spend the money but the GT was acting like a gas pig