annoying lites [Archive] - GrandAmGT.com Forum

PDA

View Full Version : annoying lites


Ultralarry
07-25-2005, 08:11 AM
Hello, I have a 99 GT. The (ABS) and the (TRAC OFF) lites keep coming on. The brake pads are in good shape. Plenty of pad left. They seen to turn on as soon as I go in gear and step on the gas. It is like a little hesitation then alarm and lites. If in neutral after I start the car, they arent on. But in gear and go, here they come. Any help will be appreciated. Thanks, Larry

action
07-25-2005, 10:11 AM
ABS sensor on its way out. Have someone with a tech II check it for you.

sicc
07-25-2005, 10:16 AM
Yep. There's a few wires that run out from behind your wheel bearing assembly on each side. One of mine were completely cut through somehow and I got the same lights randomly. If that's the case you will just need to get that wheel bearing assembly replaced.

mcgrady
07-25-2005, 03:02 PM
Hello, I have a 99 GT. The (ABS) and the (TRAC OFF) lites keep coming on. The brake pads are in good shape. Plenty of pad left. They seen to turn on as soon as I go in gear and step on the gas. It is like a little hesitation then alarm and lites. If in neutral after I start the car, they arent on. But in gear and go, here they come. Any help will be appreciated. Thanks, Larry

Is the service vehicle light on as well?

We've had pretty good luck at the shop unhooking the ABS sensor, cleaning it up and packing it with dielectric grease when reconnecting. Mine was coming on about once a week and hasn't come on for over a month now that I've used the grease on the connections.

the01gt
07-26-2005, 12:08 AM
sometimes when I hit extremely hard bumps my trac off light comes on...

Alfonso
07-26-2005, 03:52 PM
I had exactly the same problem. I remove the ABS conector on all four wheels and spray WD-40 on it, I conect it again, and problem goes off. Try this before you bought an expensive wheel sensor.

Ultralarry
07-29-2005, 08:13 AM
Someone on this forum said if you dont use the emergency brake enough that can cause the abs lite and trac off lite to come on. Well i used the brake everytime I stopped one day, and now for the last three days, no more lites on. Could it realy be?

NeverSatisfied
08-02-2005, 11:18 AM
I have this same problem on mine except my lights (ABS and Trac Off) are on all the time. I was told it could be a speed sensor. I also have a 'thudding' and 'creaking' noise happen when I push on the breaks.. Any clues??

sickness
08-02-2005, 01:06 PM
I've got this same problem with my 98 GA.

AaronGAGT
08-02-2005, 07:52 PM
sometimes when I hit extremely hard bumps my trac off light comes on...

its supposed to.

As for those lights being on... usually have to replace the hub assembly.

my02gt
08-02-2005, 10:24 PM
Those lights came on for me along with my security light. Come to find out it was a Passlock Sensor and Speed Sensor. $600. But I didnt have to pay a dime.

Hot_Stud18
08-27-2005, 04:20 PM
Ok mine did this same thing yesterday, while I backing out of my driveway I got the ABS light, Trac light, and Service Engine Light after the lights came on I shut the car off and started it back up and nothing came on. My question is with a problem like this can one just let it go and not worry about it or is this something that needs atention too? I have a 2001 GT with 70k miles and since this car is getting older now it is becoming one of my beaterz now and I dont care about the lights I just wanna get me from point A to point B.

So in your opinion what would you guys do?

Oh and FYI I just had the serpentine belt and fuel filter replaced about 10 days ago if that means anything.