new Lock Cylinder and Switch....still flashing security light.. [Archive] - GrandAmGT.com Forum

PDA

View Full Version : new Lock Cylinder and Switch....still flashing security light..


tenstrum
08-19-2005, 11:58 AM
OK, so about 4 months ago my key wouldn't turn and I had to have my car towed to the dealership.
What eventually happened was that I had to get a new Ignition Lock Cylinder and a new Ignition Switch.
Why both you ask????
Because apperantly, they were so FUBAR'ed that the only way to replace them was to drill them out....

OK, so they got my new parts in, recoded for key, and off I went after spending $500....
OK end of story right?????? WRONG!

About 2 weeks after getting my new Lock Cylinder and Switch my security light comes on while drivng. I'm like WTF??????
It doesn't come on again for several weeks. Then one day, I go to start my car and SUPRISE!!!!, I get the flashing security light and I have to wait 10 minutes before my car starts.
So this has been going on now for the past couple of months. The security light will come on about once a week while I'm driving and about once a month my car won't start due to the flashing security light and I have to wait the 10 minutes to start it.

Everything I can find says that the Passlock sensor is screwed up. Shouldn't that have been replaced with the new parts????
However, before I take it back to the dealer I thought about trying one of my spare keys just in case my main key (the one they used to code the new cylinder with) is worn out.

Do you all think I should try using a different key, get a new set of keys, or just drive straight to the dealer? How would I convince the dealer that they didn't fix the original problem? The new Lock Cylinder and Switch have a 1 year warranty so any problems should be covered, but I'm worried the dealer will try to charge me money when I'm 99% sure they didn't get the original problem fixed.

What would you all do? And what do you think the problem is?

sc02grandam
08-19-2005, 12:16 PM
you could try bypassing the passlock module and just live without having the extra security

tenstrum
08-19-2005, 01:24 PM
I would prefer to get the actually problem fixed.

cheetoh
09-27-2005, 01:46 PM
Did you ever resolve this issue? I am having the same problem!!

tenstrum
09-29-2005, 07:12 AM
No, I went back to the dealer and unfortunately the warranty on my lock cyclinder has expired and it was going to cost an arm and a leg to fix again. So at this point, I have decided to live with it and if it starts getting really bad, then I'm just going to bypass it.

brsexton
09-29-2005, 08:55 AM
No, I went back to the dealer and unfortunately the warranty on my lock cyclinder has expired and it was going to cost an arm and a leg to fix again. So at this point, I have decided to live with it and if it starts getting really bad, then I'm just going to bypass it.


I thought all GM parts had a 12 month warranty. If this was done only 4 or 5 months ago, I would think it should still be under warranty. You could also try using a new key. I have read that a worn key will cause the light to come on.

tenstrum
09-29-2005, 10:48 AM
Unfortunately it was a 12 month/12,000 mile warranty and I'm about 5,000 miles over....

Yep, Ive done a lot of driving. I'm the only one of my friends that has a 4 door car so guess whose car gets taken 95% of the time???? That's right! MINE!

Anyone tried bypassing the passlock sensor? How hard is it?

cheetoh
09-29-2005, 11:42 AM
Yeah, If anybody knows how to bypass the sensor, I would like to know too.

reeotch31
10-01-2005, 06:39 PM
you have to take out your gauges, take off your center console plastic piece, take out your radio(just so you have enough room, but i have big hands) and take out the 2 bolts that hold in the ignition. In the back of the plastic piece holding in the ignition there is a black cable, just pop that out and you're all set.