Coolant Smell [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Coolant Smell


GAGT7386
09-15-2005, 05:41 AM
Alright I know all about the LIM problems, but I had mine replaced under warrenty. I had flushed out my coolant this spring, and ever since then I think that my car runs slightly hotter then it did before. Also now every two weeks or so, if I let my car idle it begins to smell like antifreeze, and then I'll get a low coolant warning light. Wondering if anyone has any suggestions?

Thanks

MetaGTP1
09-15-2005, 08:43 AM
Sounds like you may have a coolant leak. Check around the water pump, heads and under the car. Look to see if there is any fluid under where your car was parked.

plourded
09-15-2005, 09:55 AM
it happen to me too, after I did a coolant flush at GM sometime I will smell coolant. I don't see any leaks, don't know if you find out let me know

atc3434
09-15-2005, 10:16 AM
Bad cap maybe? I had a bad cap, soon as the car would heat up idling, I'd get coolant out the overflow cap. Keep an eye on the LIM gaskets though... check the oil make sure its not getting milky. Some people have had re-occuring issues with them.

GAGT7386
09-15-2005, 10:09 PM
I was thinking bad cap also, I am going to replace that tomorrow. I just changed my oil not to long ago, I have never actually seen milky oil so is it pretty obvious if there is a mixture?

MattBatt
10-08-2005, 01:35 AM
I think I might have a bad cap the only place that the fluid is leaking is through the overflow valve. Could that also be the thermostat. which is more likely? the thermostat sounds like a pain to get to.
99 v6 105000 miles replaced LIM gaskets 3 times.