up and down idle [Archive] - GrandAmGT.com Forum

PDA

View Full Version : up and down idle


Gramp's GT
09-30-2005, 07:35 PM
Sometime my GA at start up will not idle smooth. This only happens every so often so it is hard to pin point. The idle will go up and down between 2 or 300 rpms back up to normal then back down again. This will happen for about 30 or 40 seconds or until I drive off and then everything is find. It does not stall.

Over the past year I have changed my fuel filter, replaced the fuel pump 2 years ago, had the fuel line and injectors cleaned out by the dealership a couple of months ago.
I have searched for this thread and it appears to happen to others however no advice on what the cause is or the cure.
Is this a warning that my fuel pump is getting ready to pack it in again?

MetaGTP1
09-30-2005, 08:45 PM
Sometime my GA at start up will not idle smooth. This only happens every so often so it is hard to pin point. The idle will go up and down between 2 or 300 rpms back up to normal then back down again. This will happen for about 30 or 40 seconds or until I drive off and then everything is find. It does not stall.

Over the past year I have changed my fuel filter, replaced the fuel pump 2 years ago, had the fuel line and injectors cleaned out by the dealership a couple of months ago.
I have searched for this thread and it appears to happen to others however no advice on what the cause is or the cure.
Is this a warning that my fuel pump is getting ready to pack it in again?Have you checked the IAC(Idle Air Control) sensor?

Gramp's GT
09-30-2005, 09:48 PM
Nope ...didn't know there was one. What do I check when I find out where it is?

freeze12
09-30-2005, 09:51 PM
Try spraying some throttlebody cleaner into the idle air control valve. Look down the throat of the throttlebody & near the top you will see a passage in the side of the throttlebody right where the IAC valve is. spray the cleaner in the hole using the wand & cleaner so You get the spray in the hole.Spray it & wait a short time & repeat,then do a burst of spray. Put everything together & start the car. The idle will be rough until it clears the cleaner out. If it is still rough the You will have to spray into the hole with the car running & goosing the throttle. The Pintle on the IAC carbons up resulting in a rough idle.

coupe
10-01-2005, 07:12 AM
Do a search on this, you will find ALOT of people have this problem and no one has found a fix yet. You will spend a small fortune changing out small parts and in the end you will still have this problem.

Gramp's GT
10-01-2005, 09:44 AM
I will try the ideas. I will give it a try.

onesexyga
10-01-2005, 09:51 AM
My ga does that from time to time. Doesnt seem to do anything bad tho. Just funky for a second then clears up.

Panacea
10-01-2005, 11:51 AM
This happened on a regular basis for me. I had my fuel injectors cleaned and a bad fuel injector replaced and so far (crosses fingures) it hasn't returned, or so I haven't noticed it. Don't know/guarantee that this is a fix, but from my experience it seems to have helped.

andrewe77
10-02-2005, 05:41 PM
Mine does it. I think the computer gets confused sometimes at startup but it always goes away if I goose the throttle.

coupe
10-02-2005, 05:43 PM
I thought it was PCM related at first also, but its not, trust me its not the PCM.

Azazel
10-26-2005, 04:01 PM
This happend to me. The only thing we did to fix the problem we clean my really dirty MAF(Mass Air Flow Sensor). It fixed the probem right up. Havent had it since and its been about 4 months.