power steering prob [Archive] - GrandAmGT.com Forum

PDA

View Full Version : power steering prob


ancona46
10-12-2005, 03:40 PM
my ps lately when its a cold morning when i first start the car and pull out of the driveway i hear the pump whine a little like the fluid is low "its not low" and the steering is a little tight for a second anyone have an idea of what it is?

Panacea
10-12-2005, 03:47 PM
Well, I just had the power steering gear replaced in mine. When the car was cold I heard it whine, but the power steering fluid was low too. Turned out the gear was leaking...

It could be a number of things, power steering pump, hoses, gear, etc. If you're under warranty, get it fixed.

juanvan
10-13-2005, 03:05 PM
Mine is starting the same thing, I was wondering what might be causing that.. Well looks like it time to take it out ouch....

manic mechanic
10-13-2005, 06:27 PM
You could also try flushing out the power steering fluid.

It has worked for a few people.

Mike Jung
10-13-2005, 06:41 PM
You could also try flushing out the power steering fluid.

It has worked for a few people.
Or do the DYI with a Turkey baster & change it out a few times from the reservoir tank.

1hotgagt
10-13-2005, 07:29 PM
it could be the gears are to tight and they are binding

badboy2451
10-13-2005, 10:15 PM
mayeb just cause its cold and it needs to warm up??? makes sense to me atleast lol

ancona46
10-14-2005, 08:55 AM
mayeb just cause its cold and it needs to warm up??? makes sense to me atleast lol


i would understand that if it was a older car i only have like 24k on it......and its not even that cold out when it does it its like 55-60ish

replica9000
10-24-2005, 05:45 AM
Mine kinda does this when i'm backing out to the right. I already has the steering pump replaced. I think it's cuz I need a ball joint though....

tenspeed
10-24-2005, 09:54 AM
I had a Ciera that did the same thing. The first turn was stiff. It turned out to be a worn rack. They found it during a state inspection.

Lab Rat
10-24-2005, 11:00 AM
Seafoam tranny and ps tune up worked for me. I was a little low on fluid and figured the seafoam would not hurt. All better now.

hofulstrof
10-24-2005, 12:14 PM
try tightening the belt a bit. this happened on my parents hyundia

action
10-28-2005, 12:37 PM
Cant tighten the belt on these cars, its serpentine with a spring loaded tensioner

Slim
10-28-2005, 12:51 PM
My ps pump whines like crazy when it's really cold outside and a little bit when it's just normal cold. I think it's because the fluid is thicker when it's cold outside. I'd change it, but my car is going back in Feb, so I don't care anymore.