Click Click Boom [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Click Click Boom


Sleepwalkr
10-18-2005, 09:04 PM
Ok, so for the past 2 months or so, theres been a ticking/clicking sound coming from my hazard button. You know.... its the same clicking sound that comes on when you turn on the hazards or the turn signal. However, it started clicking on its own, speratically, and for no apparent reason.... and very fast...... about twice as fast as when you turn on the blinkers. It does it more so after the blinkers have been on, then go off. Everything works fine....blinkers, hazard lights, all fine. At one point, I removed the hazard switch fuse, but then I lost the use of the turn signals. It doesn't do it all the time, but enough to make me turn the radio up extra loud to avoid hearing the damn thing. (Plus its driving my wife crazy) Anyways, I was hoping it was a matter of replacing the hazard switch, so I bought one through my brother-in-law at his body shop for $23. They wanted $109 at the dealer.... gimme a fricken break. (plus another $90 to install it)
So, I put it in this afternoon, and it still does it! My only guess now is that its the turn signal lever itself. Maybe a short? Bad wiring of some kind? I'm not sure. Plus, twice now in the last 3 or 4 weeks, right after I start my car, a tiny little wisp of "smoke" rises up from the steering column, near the turn signal. Kinda like right after you light a cigarette, that little smoke that rises from the cigarette...... it looks kinda like that, but it only lasts about 1 second. Anyways, does anyone have any other ideas before I spend the $60-$75 for a new turn signal lever?
Thanks in advance for any suggestions.

Panacea
10-18-2005, 09:22 PM
Yeah it's your turn signal stalk, or at least thats what it sounds like... You must have been gone that whole period when everyone was having problems. lol

rancor352
10-18-2005, 09:31 PM
I think its the stalk, I replaced one in a friends 99 gt and that fixed the problem, and I may have one I could sell ya, used of course but i think it came from 04 se with 14k, If your intreseted I'll go see if i could dig it up from the depths of my parts storage/basement, and get back with a price.

Sleepwalkr
10-19-2005, 08:22 PM
Yeah it's your turn signal stalk, or at least thats what it sounds like... You must have been gone that whole period when everyone was having problems. lol

Well, I remember when everyone was having issues with their turn signals not working correctly..... and so did I. If you're talking about the recall one, then yes, I had that replaced. Thats actually one of the reasons I thought my newest problem was the hazard button the dealer replaced.