engine ticking [Archive] - GrandAmGT.com Forum

PDA

View Full Version : engine ticking


1hotgagt
10-20-2005, 09:09 PM
when ever i start my car i get that annoying ticking sound which i think is coming from the valves can this be fixed anyway like replacing the valves and maybe putting in rolling rockers or something?

GrahamKracka
10-20-2005, 09:36 PM
normal

Mike Jung
10-20-2005, 10:11 PM
IMO:

Don't use Fram oil filters.

They have sucky anti-drain valves on their oil filters.
Allowing the oil to drain past the oil filter into the oil pan over-night.
Leaving the oil filter empty during start-up.

Can we say dry starts.

badboy2451
10-20-2005, 10:59 PM
how does that have something to do with the ticking???

Mike Jung
10-20-2005, 11:02 PM
how does that have something to do with the ticking???
Lack of oil in the valvetrain causes ticking.

Which could be caused by a bad anti-drain valve in the oil filter (which is a common problem with Fram oil filters by design)
or also using really thick oil in cold weather.
= lack of oil flow during cold starts.

badboy2451
10-20-2005, 11:26 PM
ooo, makes sense now...fram the only filter known for this?

Mike Jung
10-20-2005, 11:30 PM
ooo, makes sense now...fram the only filter known for this?
I also heard on some engines.
Purolator PureOne (& maybe Mobil 1) oil filters could cause this problem of ticking.
From lack of oil flow during start-up, because they filter too well.

High filtering = lower oil flow.

Where K&N = high oil flow, but lower filtering.

PS: IIRC, Fram also makes Pennzoil & (US) Honda (but to Honda's specs-?) oil filters. & Canadian Tire (house brand) MotoMaster oil filters.