Got LIM Fixed now more problems.... [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Got LIM Fixed now more problems....


00blackGT
10-23-2005, 09:21 AM
Took my car do the dealer for a huge paint chip they took out of my door..and ended up telling them my low coolant light was coming on...So they check its out and turns out my LIM was bad and some senior in my rad was bad to. So they fixed all of that...Now my tranny will go to 4K RPM's then go into a "Neutral" stage and die to 3K and then kick back in...and my belts are squeeling. SO i what i am askin is what all is involed in replacing the LIM...Thanks!

KrustyTC
10-23-2005, 10:37 AM
It involves removing the intake manifold, basically the entire top of the engine. They shouldn't have messed with the belt though. It is possible they got some coolant or oil or something on the belt and that is whats making it squeel. They may also have somehow messed up the belt tensioner but I doubt it.

The problem with the tranny sounds like they forgot to plug in a sensor or control plug. Bring it back and have them recheck all the connections.

I just had mine done and the worst that happened was I had to buy a new fuel pressure regulator. Mine started to leak after the install.

later,
KrustyTC

sicc
10-23-2005, 11:35 AM
Sounds like they didn't refill your transmission fluid completely. I had this problem as well.

Graxall
10-23-2005, 11:43 AM
i just got my upper and lower intake manifolds redone...my car runs great now...

00blackGT
10-23-2005, 12:40 PM
Yea, i was hoping my car would be running great to...But as you can tell its not...I think its time for me to find another GM "Certified" dealership.....

00blackGT
10-25-2005, 10:16 AM
Well today my car went back to the shop...It dumped all the coolant and started to overheat...And also found 3 bolts that were complety lose...Lets see what they said this time..

Ajaxus
10-25-2005, 07:48 PM
eh, i have coolant problems now too, i carry a bottle of dex around in the car until i can get in to the mechanic... yay.. :(

MantaGreen97
10-25-2005, 07:58 PM
Yea, i was hoping my car would be running great to...But as you can tell its not...I think its time for me to find another GM "Certified" dealership.....

Hopefully they fix it right, without trying to charge you more. Really it's time to find an independent mechanic/shop that knows what they are doing (and will charge less) or start doing your own work. GM dealerships are just as hit and miss as any other type of garage, in my experience, and they ain't cheap. The dealership where I purchased my car has a $99/hr CDN. labour rate! I don't know what they are smoking but surely they don't have any problems affording it since the place is always busy with cars.

Word-of-mouth reputation and experience with your car and engine type (which is pretty common) is really the best way to find a decent garage I think.