Horn Issues [Archive] - GrandAmGT.com Forum

PDA

View Full Version : Horn Issues


ALPHA Q UP
12-30-2005, 02:21 PM
I have an 02 gt and had the problem with the turn signal clicking, I fixed that but didn't press in the horn pin when I was putting the multifunction switch back in.

So basically I bent that, and the horn didn't work. I took the switch apart and straightened out the horn switch so that it rides on the gold ring inside the steering column. Horn still doesn't work. Not sure what else to check, I did notice that if I grounded out the gold disk inside the steering column the horn works.

atc3434
12-30-2005, 03:09 PM
Check the ground under the hood. If you ground it out in another place and it works, its pretty likely the regular ground is causing you problems. The ground for my 99 SE was on the drivers side fender. Its a junction box that has all black wires going to it, and its screwed onto the fender. This is a ground for a bunch of stuff. I took mine off once not knowing it was the ground, and ended up with a bunch of weird grounding related problems, including my horn not working, and some fast clicking blinkers. Worth a shot.

ALPHA Q UP
12-31-2005, 07:56 AM
I am trying to understand how the horn or our cars works.

Correct me if I'm wrong. It is a reverse or negative ground system where power is always going to the horn and when you press in on the steering wheel, it grounds out the horn, therefore activating the horn.

So if I have power at the horn pin in the multifunction switch and on the gold ring in the steering column that the pin sits on, that part works. When I press in on the steering wheel and nothing happens, that means that the loop or ground is not completing when the horn switch is pressed.

That leads me to believe that the button that is activated when you press on the steering wheel isn't working. How would I go about testing this?

AaronGAGT
01-01-2006, 12:19 PM
if you figure this out... please let me know about the fix. I did the same EXACT thing you did and bent that gold ring thing.

And you're correct about it being a reverse ground system

brsexton
01-01-2006, 05:11 PM
Check the fuse. I was messing with my column and blew my horn fuse some how. Its in the fuse box under the hood.

ALPHA Q UP
01-04-2006, 10:15 AM
I checked the fuse under the hood and its not that.

I just have to get around to testing the actual horn button that is part of the airbag. I think that's where the problem is.

ALPHA Q UP
02-25-2006, 08:41 AM
I got this problem fixed.

It is the gold ring or cam that the horn ring sits on. The GM part # is 26099571 its about $20.00 or so.

I didn't do it myself, but had it done at the dealer, I believe they charged an hours labor on this.

iceman
02-25-2006, 11:41 AM
And you're correct about it being a reverse ground system


No he's not.

Horn is always grounded, pressing the horn button sends +12v to the trumpets to complete the circuit.

Windows95
12-15-2007, 01:29 PM
Sorry to resurrect such an old thread, but I just recently had the same problem and thought Iíd add my two cents in case anyone else gets stuck. Iíd read some condensed instructions about cleaning the multiswitch, and wasnít aware of the horn pin. Needless to say I bent the pin and disabled my horn in the process. Took me about two days to realise my horn was broken. Fortunately I found this forum and was able to figure out what the problem was. My horn now works after about 20 minutes of fairly straightforward repairs.

First thing is to make sure itís the switch itself thatís broken, and not a fuse blown or the horn itself. If you have a key remote, hit your panic alarm and make sure you can hear the horn going off. If not, these instructions wonít help.
First step for me was to remove and disassemble the multiswitch again. Have a real good look at the horn pin. If itís been bent at all, it wonít slide properly. Pull the pin out and with some pliers *gently* bend it straight again. Reseat the pin in the multiswitch and make sure it slides properly, it shouldnít stick at all.

After I fixed the pin, I put the multiswitch back together and reinstalled it on the steering column. Unfortunately the horn still didnít work. I then looked at the gold ring that the horn pin rides along, and realised it was somewhat warped. Iím assuming the gold ring should be fairly smooth, so I took needle nose pliers and *carefully* tried to straighten it out as best I could. It was perfect, but when I tried my horn it worked again. Try turning your steering wheel to its limits a few times as well to make sure it works in all positions and doesnít accidentally activate when it shouldnít.

As Alpha Q Up said, the gold ring part is fairly cheap (about $20), but you could be looking at some nasty labour costs. While Alpha Q Up got a good deal, it sounds like the typical cost for the repair is two and a half hours labour, as the whole steering wheel needs to be removed to replace it (not a fun job).