BCM Issues? [Archive] - GrandAmGT.com Forum

PDA

View Full Version : BCM Issues?


Wildman
01-04-2006, 05:10 PM
Ok, so the other day my car intermitently started not responding to my keyless remote. Then when I start the car, I get any random combination of lights such as SES, SVS, Brake, Anti-Lock, Trac Off, Battery, Security. Also none of the guages work. The backlighting and everything lights up but the guages do not budge. Also the Odometer and tripometer light up, but never accumulate any milage while I am driving. Sometimes when I shut the car off and turn it back on, I get a different combination of lights that come on the dash. For example yesterday I had security, battery, SES, brake, anti-lock. Today I just had Battery, anti-lock, Brake. I am thinking that maybe the BCM is going bad so I wanted any advice from anyone who knows of this issue. Also, just incase, where can I get a BCM for my 99 Alero.

iceman
01-04-2006, 06:16 PM
It could be the BCM or the IPC, you can get the dealer or someone with a tech2 to run through the diag procedures. There should definitely be codes set that will clue them in.

Also, don't hold me to this, but I'm not sure if you can do a direct BCM swap from a junker. That is beyond my knowledge. My BCM had to be replaced due to a water leak, and there is a feature programming procedure that has to be done, and after (i think it is 20) ignition off/on cycles, it is permanently locked.

chavezgt
01-04-2006, 07:41 PM
Dude, check out my post below. It sounds like we're having around the same problem. I had my BCM replaced (& reprogrammed), and I'm still having the same problems. Good luck, and let me know if you find a solution.

Wildman
01-05-2006, 05:01 PM
Can anyone tell me where the BCM is located?

Ajaxus
01-05-2006, 05:24 PM
http://www.grandamgt.com/forum/showthread.php?t=17559&highlight=bcm+located

ran a search for "bcm located" first post in that thread. yw.